summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-08-23 17:37:49 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-27 22:52:41 +0100
commit10c1a27501a32740a03c3c6c0684c7d24374af08 (patch)
treeafda44d19ae7aec3ed53b609e69b9ce358aad835 /meta/recipes-core/systemd
parentc0fc43c228acd44499d9a1c257ec5e4cf42ed050 (diff)
downloadopenembedded-core-contrib-10c1a27501a32740a03c3c6c0684c7d24374af08.tar.gz
systemd: Print a buildtime warning about the status with musl
It is possible if a user really has to use it, but not recommended. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd_242.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_242.bb b/meta/recipes-core/systemd/systemd_242.bb
index b368ca8a2c..cfa9c079ab 100644
--- a/meta/recipes-core/systemd/systemd_242.bb
+++ b/meta/recipes-core/systemd/systemd_242.bb
@@ -619,6 +619,12 @@ python __anonymous() {
d.setVar("INHIBIT_UPDATERCD_BBCLASS", "1")
}
+python do_warn_musl() {
+ if d.getVar('TCLIBC') == "musl":
+ bb.warn("Using systemd with musl is not recommended since it is not supported upstream and some patches are known to be problematic.")
+}
+addtask warn_musl before do_configure
+
ALTERNATIVE_${PN} = "halt reboot shutdown poweroff runlevel resolv-conf"
ALTERNATIVE_TARGET[resolv-conf] = "${sysconfdir}/resolv-conf.systemd"