aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_216.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-01-29 12:44:20 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-03 14:53:43 +0000
commit2a675bc63b22724f12e6ed6ff58d0f1d1e0d3b29 (patch)
treea4b6ff72d8a4a4e71a542c7590fe3b053d7d4237 /meta/recipes-core/systemd/systemd_216.bb
parente1a3c6e218779e2237c494e58209c06b871c47c4 (diff)
downloadopenembedded-core-contrib-2a675bc63b22724f12e6ed6ff58d0f1d1e0d3b29.tar.gz
systemd: Backports fixes to 216
Fix systemd-timesyncd assertion when networkd is disabled then we now do not create /run/systemd/netif/links but timesyncd needs it. So lets manually create this file when networkd is disabled so timesyncd can still function When enabling systemd-timesyncd we need systemd-timesync user Backport patches to enable timesyncd when resolved and networkd are disabled replace the resolv.conf symlinink patch with a proper backport Change-Id: I53f1a53eec4e4a4dbdfb7e8cd155d544ee5d81ec Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/systemd/systemd_216.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_216.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta/recipes-core/systemd/systemd_216.bb b/meta/recipes-core/systemd/systemd_216.bb
index b49bd72e62..569e88c240 100644
--- a/meta/recipes-core/systemd/systemd_216.bb
+++ b/meta/recipes-core/systemd/systemd_216.bb
@@ -35,11 +35,13 @@ SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;branch=master;protocol=
file://0001-Make-root-s-home-directory-configurable.patch \
file://0001-systemd-user-avoid-using-system-auth.patch \
file://0001-journal-Fix-navigating-backwards-missing-entries.patch \
+ file://0001-tmpfiles-make-resolv.conf-entry-conditional-on-resol.patch \
+ file://0001-build-sys-do-not-install-tmpfiles-and-sysusers-files.patch \
+ file://0001-build-sys-configure-the-list-of-system-users-files-a.patch \
file://touchscreen.rules \
file://00-create-volatile.conf \
file://init \
file://run-ptest \
- ${@bb.utils.contains('PACKAGECONFIG', 'resolved', '', 'file://0001-tmpfiles.d-etc.conf-disable-resolv.conf-symlink.patch', d)} \
"
S = "${WORKDIR}/git"
@@ -151,6 +153,12 @@ do_install() {
# Enable journal to forward message to syslog daemon
sed -i -e 's/.*ForwardToSyslog.*/ForwardToSyslog=yes/' ${D}${sysconfdir}/systemd/journald.conf
+ # its needed in 216 upstream has fixed it with 919699ec301ea507edce4a619141ed22e789ac0d
+ # don't order journal flushing afte remote-fs.target
+ sed -i -e 's/ remote-fs.target$//' ${D}${systemd_unitdir}/system/systemd-journal-flush.service
+ # this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it
+ # for existence else it fails
+ ${@bb.utils.contains('PACKAGECONFIG', 'networkd', '', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${libdir}/tmpfiles.d/systemd.conf', d)}
}
do_install_ptest () {
@@ -182,7 +190,7 @@ SYSTEMD_PACKAGES = "${PN}-binfmt"
SYSTEMD_SERVICE_${PN}-binfmt = "systemd-binfmt.service"
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} += "--system systemd-journal-gateway"
+USERADD_PARAM_${PN} += "--system systemd-journal-gateway; --system systemd-timesync"
GROUPADD_PARAM_${PN} = "-r lock; -r systemd-journal"
FILES_${PN}-analyze = "${bindir}/systemd-analyze"