aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2016-01-25 11:04:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-26 22:31:09 +0000
commita9db2b514e1f1093cd80a7793813136f26e531da (patch)
tree56f723a1302433b9431960fc5a990ad5c4398c6f /meta/recipes-core/systemd/systemd
parent58d47cdf91076cf055046ce9ec5f3e2e21dae1c0 (diff)
downloadopenembedded-core-contrib-a9db2b514e1f1093cd80a7793813136f26e531da.tar.gz
systemd: make TEST_DIR configurable
1. make TEST_DIR configurable, and configure it to ptest dir, since the *.service for test are installed into ptest dir. 2. always follow symbolic links in SOURCE when copy test files to install dir, since some *.service under test dir are linked to ../unit/*.service which are not installed into ptest dir Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/systemd/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd/0001-make-test-dir-configurable.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd/0001-make-test-dir-configurable.patch b/meta/recipes-core/systemd/systemd/0001-make-test-dir-configurable.patch
new file mode 100644
index 0000000000..7d06371c95
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd/0001-make-test-dir-configurable.patch
@@ -0,0 +1,64 @@
+From 3eeec270d3af166e3bc09537626850562487742b Mon Sep 17 00:00:00 2001
+From: Roy Li <rongqing.li@windriver.com>
+Date: Fri, 22 Jan 2016 16:44:11 +0800
+Subject: [PATCH] make test dir configurable
+
+Upstream-Status: Pending
+
+test maybe be run on target in cross-compile environment, and test dir
+is not the compilation dir, so make it configurable
+
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+---
+ Makefile.am | 2 +-
+ configure.ac | 7 +++++++
+ 2 files changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 931d13f..7155ec7 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -209,7 +209,7 @@ AM_CPPFLAGS = \
+ -DROOTLIBDIR=\"$(rootlibdir)\" \
+ -DROOTLIBEXECDIR=\"$(rootlibexecdir)\" \
+ -DROOTHOMEDIR=\"$(roothomedir)\" \
+- -DTEST_DIR=\"$(abs_top_srcdir)/test\" \
++ -DTEST_DIR=\"$(testdir)/test\" \
+ -I $(top_srcdir)/src \
+ -I $(top_builddir)/src/basic \
+ -I $(top_srcdir)/src/basic \
+diff --git a/configure.ac b/configure.ac
+index 76090a1..b02968d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1411,6 +1411,11 @@ AC_ARG_WITH([roothomedir],
+ [],
+ [with_roothomedir=/root])
+
++AC_ARG_WITH([testdir],
++ AS_HELP_STRING([--with-testdir=DIR], [test file directory]),
++ [],
++ [with_testdir=${abs_top_srcdir}])
++
+ AC_ARG_WITH([pamlibdir],
+ AS_HELP_STRING([--with-pamlibdir=DIR], [Directory for PAM modules]),
+ [],
+@@ -1503,6 +1508,7 @@ AC_SUBST([pamconfdir], [$with_pamconfdir])
+ AC_SUBST([rootprefix], [$with_rootprefix])
+ AC_SUBST([rootlibdir], [$with_rootlibdir])
+ AC_SUBST([roothomedir], [$with_roothomedir])
++AC_SUBST([testdir], [$with_testdir])
+
+ AC_CONFIG_FILES([
+ Makefile
+@@ -1593,6 +1599,7 @@ AC_MSG_RESULT([
+ lib dir: ${libdir}
+ rootlib dir: ${with_rootlibdir}
+ root home dir: ${with_roothomedir}
++ test dir: ${with_testdir}
+ SysV init scripts: ${SYSTEM_SYSVINIT_PATH}
+ SysV rc?.d directories: ${SYSTEM_SYSVRCND_PATH}
+ Build Python: ${PYTHON}
+--
+1.9.1
+