aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-04-17 00:01:44 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-16 23:05:24 +0100
commit6ae99136f1c1c59f4e55331c43cf0c0bac5abcdd (patch)
treedc2c65bcf2e46a658f3dbd40cd801ee068d11ed3 /meta/recipes-core/systemd/systemd
parent7863a3c7f2d619c63ddb25883a774af6c9eb3143 (diff)
downloadopenembedded-core-contrib-6ae99136f1c1c59f4e55331c43cf0c0bac5abcdd.tar.gz
systemd: use AC_CHECK_TOOL instead of AC_PATH_TOOL when checking objcopy, strings, gperf
* with external toolchain I have different HOST_PREFIX and HOST_SYS AC_PATH_TOOL is using HOST_SYS as prefix and fails to find objcopy then it tries objcopy without prefix which is found on host, but that objcopy does not work for arm libs * with internal toolchain gperf is not prefixed with HOST_PREFIX, but fallback to "gperf" only finds the one in native sysroot first * based on http://lists.linuxtogo.org/pipermail/openembedded-core/2013-April/037985.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd/0001-configure-use-AC_CHECK_TOOL-for-objcopy-strings-and-.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd/0001-configure-use-AC_CHECK_TOOL-for-objcopy-strings-and-.patch b/meta/recipes-core/systemd/systemd/0001-configure-use-AC_CHECK_TOOL-for-objcopy-strings-and-.patch
new file mode 100644
index 0000000000..d847bbc202
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd/0001-configure-use-AC_CHECK_TOOL-for-objcopy-strings-and-.patch
@@ -0,0 +1,41 @@
+From d6f92bcbbae9a577adb9588c7b2783a5d0bf343d Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Tue, 16 Apr 2013 14:20:41 +0200
+Subject: [PATCH] configure: use AC_CHECK_TOOL for objcopy, strings and gperf
+
+* using AC_PATH_TOOL does not allow to override it from shell environment
+ which is useful when cross-compiling
+* with external toolchain I have different HOST_PREFIX and HOST_SYS
+ AC_PATH_TOOL is using HOST_SYS as prefix and fails to find objcopy
+ which is available only as ${TARGET_PREFIX}objcopy then it tries
+ objcopy without prefix which is found on host, but that objcopy
+ does not work for !host (e.g. arm when building on x86) libs
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+Upstream-Status: Submitted
+http://lists.freedesktop.org/archives/systemd-devel/2013-April/010468.html
+
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 33b0ca9..519f1a9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -86,9 +86,9 @@ GOBJECT_INTROSPECTION_CHECK([1.31.1])
+ AM_CONDITIONAL([HAVE_INTROSPECTION], [false])
+ enable_introspection=no])
+
+-AC_PATH_TOOL(OBJCOPY, objcopy)
+-AC_PATH_TOOL(STRINGS, strings)
+-AC_PATH_TOOL(GPERF, gperf)
++AC_CHECK_TOOL(OBJCOPY, objcopy)
++AC_CHECK_TOOL(STRINGS, strings)
++AC_CHECK_TOOL(GPERF, gperf)
+ if test -z "$GPERF" ; then
+ AC_MSG_ERROR([*** gperf not found])
+ fi
+--
+1.8.1.5
+