aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-serialgetty.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-12-19 16:23:40 +0800
committerRobert Yang <liezhi.yang@windriver.com>2017-12-20 09:51:34 +0800
commiteffbd3d25e0509d870f5a658dd24c93c27924cba (patch)
tree7165bb036f08e333e4f7a52d9fdcd973d6ae8dda /meta/recipes-core/systemd/systemd-serialgetty.bb
parent8321b1389864798845fb943888e43a89c60a8d4c (diff)
downloadopenembedded-core-contrib-effbd3d25e0509d870f5a658dd24c93c27924cba.tar.gz
systemd: inherit distro_features_checkrbt/systemd
Use distro_features_check so that we can have a uniform controller. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-core/systemd/systemd-serialgetty.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-serialgetty.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb b/meta/recipes-core/systemd/systemd-serialgetty.bb
index d9347163b5..d67a3c91b4 100644
--- a/meta/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
@@ -11,6 +11,10 @@ SRC_URI = "file://serial-getty@.service"
S = "${WORKDIR}"
+# As this package is tied to systemd, only build it when we're also building systemd.
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "systemd"
+
do_install() {
if [ ! -z "${SERIAL_CONSOLES}" ] ; then
default_baudrate=`echo "${SERIAL_CONSOLES}" | sed 's/\;.*//'`
@@ -43,10 +47,4 @@ do_install() {
FILES_${PN} = "${systemd_unitdir}/system/*.service ${sysconfdir}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-# As this package is tied to systemd, only build it when we're also building systemd.
-python () {
- if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
- raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
-}
-
ALLOW_EMPTY_${PN} = "1"