aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-09-24 19:54:42 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-17 17:32:21 +0100
commit7d6cc169c95fecf6388a275281eb8b8f5d8eb4a2 (patch)
tree7ea555fdeb17b143e83691b7277d887eaae1bad6 /meta/recipes-core/packagegroups
parent86c6fa8175482283268dfa8782c6643a3510e0fd (diff)
downloadopenembedded-core-contrib-7d6cc169c95fecf6388a275281eb8b8f5d8eb4a2.tar.gz
Add packagegroup-core-buildessential
[Not heavily tested, but sent for discussion] task-core-sdk is too big - for example, I simply don't want to ship tcl, ever =) Historically distcc caused a large dependency graph explosion because it has a utility which uses gtk+, although that was fixed. packagegroup-core-sdk also includes coreutils, which is a bit confusing; conceptually things dependent on coreutils should pull it in explicitly, or possibly we just declare coreutils to be in the minimal build set. So packagegroup-core-buildessential is intended to be similar to Debian's "build-essential" package. It's the stuff needed by say 80+% of components, not worth repeating over and over. Signed-off-by: Colin Walters <walters@verbum.org> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/packagegroups')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb30
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-sdk.bb17
2 files changed, 31 insertions, 16 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb b/meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb
new file mode 100644
index 0000000000..164da36686
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2007 OpenedHand Ltd.
+# Copyright (C) 2012 Red Hat, Inc.
+#
+
+SUMMARY = "Essential build dependencies"
+LICENSE = "MIT"
+PR = "r0"
+
+inherit packagegroup
+
+RDEPENDS_packagegroup-core-buildessential = "\
+ autoconf \
+ automake \
+ binutils \
+ binutils-symlinks \
+ cpp \
+ cpp-symlinks \
+ gcc \
+ gcc-symlinks \
+ g++ \
+ g++-symlinks \
+ gettext \
+ make \
+ libstdc++ \
+ libstdc++-dev \
+ libtool \
+ pkgconfig \
+ "
+
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
index b00bf0704c..985bebd3b4 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
@@ -16,28 +16,13 @@ RREPLACES_packagegroup-core-sdk = "task-core-sdk"
RCONFLICTS_packagegroup-core-sdk = "task-core-sdk"
RDEPENDS_packagegroup-core-sdk = "\
- autoconf \
- automake \
- binutils \
- binutils-symlinks \
+ packagegroup-core-buildessential \
coreutils \
- cpp \
- cpp-symlinks \
ccache \
diffutils \
- gcc \
- gcc-symlinks \
- g++ \
- g++-symlinks \
- gettext \
- make \
intltool \
- libstdc++ \
- libstdc++-dev \
- libtool \
perl-module-re \
perl-module-text-wrap \
- pkgconfig \
findutils \
quilt \
less \