aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-self-hosted.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-29 11:38:34 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:50 -0700
commit424dcf7046e4ad09dcc664eb1992201195247fcf (patch)
tree26640470c5c7865aec06711fae7009304dc8fea0 /meta/recipes-core/packagegroups/packagegroup-self-hosted.bb
parentecd818f1a7a46aa0eeffe48445f2cf0db5aab67a (diff)
downloadopenembedded-core-contrib-424dcf7046e4ad09dcc664eb1992201195247fcf.tar.gz
Rename task to packagegroup
"Package group" is a much more appropriate name for these than task, since we use the word task to describe units of work executed by BitBake. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-self-hosted.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-self-hosted.bb202
1 files changed, 202 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-self-hosted.bb b/meta/recipes-core/packagegroups/packagegroup-self-hosted.bb
new file mode 100644
index 0000000000..118ff7d48b
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-self-hosted.bb
@@ -0,0 +1,202 @@
+#
+# Copyright (C) 2010 Intel Corporation
+#
+
+DESCRIPTION = "Create Basic Image Tasks"
+PR = "r11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGES = "\
+ packagegroup-self-hosted \
+ packagegroup-self-hosted-debug \
+ packagegroup-self-hosted-sdk \
+ packagegroup-self-hosted-extended \
+ packagegroup-self-hosted-graphics \
+ packagegroup-self-hosted-host-tools \
+ "
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_packagegroup-self-hosted = "\
+ packagegroup-self-hosted-debug \
+ packagegroup-self-hosted-sdk \
+ packagegroup-self-hosted-extended \
+ packagegroup-self-hosted-graphics \
+ packagegroup-self-hosted-host-tools \
+ "
+
+RDEPENDS_packagegroup-self-hosted-host-tools = "\
+ connman \
+ connman-plugin-ethernet \
+ dhcp-client \
+ e2fsprogs \
+ e2fsprogs-e2fsck \
+ e2fsprogs-mke2fs \
+ e2fsprogs-tune2fs \
+ genext2fs \
+ hdparm \
+ iptables \
+ kernel-module-tun \
+ kernel-module-iptable-raw \
+ kernel-module-iptable-nat \
+ kernel-module-iptable-mangle \
+ kernel-module-iptable-filter \
+ lsb \
+ mc \
+ parted \
+ pseudo \
+ screen \
+ vte \
+ "
+
+# eglibc-utils: for rpcgen
+RDEPENDS_packagegroup-self-hosted-sdk = "\
+ autoconf \
+ automake \
+ binutils \
+ binutils-symlinks \
+ ccache \
+ coreutils \
+ cpp \
+ cpp-symlinks \
+ distcc \
+ eglibc-utils \
+ eglibc-gconv-ibm850 \
+ file \
+ findutils \
+ g++ \
+ g++-symlinks \
+ gcc \
+ gcc-symlinks \
+ intltool \
+ ldd \
+ less \
+ libstdc++ \
+ libstdc++-dev \
+ libtool \
+ make \
+ mktemp \
+ perl-module-re \
+ perl-module-text-wrap \
+ pkgconfig \
+ quilt \
+ sed \
+ "
+
+RDEPENDS_packagegroup-self-hosted-debug = " \
+ gdb \
+ gdbserver \
+ rsync \
+ strace \
+ tcf-agent"
+
+
+RDEPENDS_packagegroup-self-hosted-extended = "\
+ bzip2 \
+ chkconfig \
+ chrpath \
+ cpio \
+ curl \
+ diffstat \
+ diffutils \
+ elfutils \
+ expat \
+ gamin \
+ gawk \
+ gdbm \
+ gettext \
+ gettext-runtime \
+ git \
+ grep \
+ groff \
+ gzip \
+ hicolor-icon-theme \
+ libaio \
+ libusb1 \
+ libxml2 \
+ lrzsz \
+ lsof \
+ lzo \
+ man \
+ man-pages \
+ mdadm \
+ minicom \
+ mtools \
+ ncurses \
+ neon \
+ nfs-utils \
+ nfs-utils-client \
+ openssl \
+ opkg \
+ opkg-utils \
+ patch \
+ perl \
+ perl-dev \
+ perl-modules \
+ perl-pod \
+ ${PTH} \
+ python \
+ python-compile \
+ python-compiler \
+ python-compression \
+ python-core \
+ python-curses \
+ python-datetime \
+ python-distutils \
+ python-elementtree \
+ python-email \
+ python-fcntl \
+ python-logging \
+ python-misc \
+ python-multiprocessing \
+ python-netclient \
+ python-netserver \
+ python-pickle \
+ python-pkgutil \
+ python-re \
+ python-rpm \
+ python-shell \
+ python-sqlite3 \
+ python-subprocess \
+ python-textutils \
+ python-unixadmin \
+ python-xmlrpc \
+ quota \
+ readline \
+ rpm \
+ setserial \
+ socat \
+ subversion \
+ sudo \
+ sysstat \
+ tar \
+ tcl \
+ texi2html \
+ texinfo \
+ unzip \
+ usbutils \
+ watchdog \
+ wget \
+ which \
+ xinetd \
+ zip \
+ zlib \
+ "
+
+
+RDEPENDS_packagegroup-self-hosted-graphics = "\
+ builder \
+ libgl \
+ libgl-dev \
+ libglu \
+ libglu-dev \
+ libsdl \
+ libsdl-dev \
+ libx11-dev \
+ python-pygtk \
+ gtk-theme-clearlooks \
+ "
+PTH = "pth"
+PTH_libc-uclibc = ""