aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-nfs.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-29 11:38:34 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:50 -0700
commit424dcf7046e4ad09dcc664eb1992201195247fcf (patch)
tree26640470c5c7865aec06711fae7009304dc8fea0 /meta/recipes-core/packagegroups/packagegroup-core-nfs.bb
parentecd818f1a7a46aa0eeffe48445f2cf0db5aab67a (diff)
downloadopenembedded-core-contrib-424dcf7046e4ad09dcc664eb1992201195247fcf.tar.gz
Rename task to packagegroup
"Package group" is a much more appropriate name for these than task, since we use the word task to describe units of work executed by BitBake. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-nfs.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-nfs.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-nfs.bb b/meta/recipes-core/packagegroups/packagegroup-core-nfs.bb
new file mode 100644
index 0000000000..e63753b3e2
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-core-nfs.bb
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "NFS tasks for Poky"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r1"
+
+PACKAGES = "\
+ packagegroup-core-nfs-server \
+ packagegroup-core-nfs-server-dbg \
+ packagegroup-core-nfs-server-dev \
+ "
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_packagegroup-core-nfs-server = "\
+ nfs-utils \
+ nfs-utils-client \
+ "
+
+# rpcinfo can be useful but only with glibc images
+GLIBC_DEPENDENCIES = "glibc-utils"
+
+RRECOMMENDS_packagegroup-core-nfs-server_append_libc-glibc = " ${GLIBC_DEPENDENCIES}"
+