aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-base.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 10:34:31 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:53 -0700
commitb41c45972a6d359f034615471959c84aee2bc456 (patch)
tree5c90e0e097572d597b99d890290c5e7a46007088 /meta/recipes-core/packagegroups/packagegroup-base.bb
parent22b4ba34ad8c08b1a97e56cdc567799f1e1460ef (diff)
downloadopenembedded-core-contrib-b41c45972a6d359f034615471959c84aee2bc456.tar.gz
packagegroup-*: add RPROVIDES for backwards compatibility
Allow references to the old task packages to continue to work. This does not add RPROVIDES for everything, just those packages that are likely to have been referred to. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-base.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-base.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-base.bb b/meta/recipes-core/packagegroups/packagegroup-base.bb
index f151591f18..217830801d 100644
--- a/meta/recipes-core/packagegroups/packagegroup-base.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-base.bb
@@ -114,6 +114,15 @@ python __anonymous () {
if "3g" in distro_features and not "3g" in machine_features and ("pcmcia" in machine_features or "pci" in machine_features or "usbhost" in machine_features):
d.setVar("ADD_3G", "packagegroup-base-3g")
+
+ # For backwards compatibility after rename
+ packages = d.getVar("PACKAGES", True).split()
+ packages.remove("packagegroup-distro-base")
+ packages.remove("packagegroup-machine-base")
+ for pkg in packages:
+ d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-base", "task-base"))
+ d.appendVar("RPROVIDES_packagegroup-distro-base", "task-distro-base")
+ d.appendVar("RPROVIDES_packagegroup-machine-base", "task-machine-base")
}
#