aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-base.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-19 13:36:45 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-23 23:01:51 +0100
commita56aed2e6e1b73bffd2bf82145fe48b82fde9292 (patch)
tree0e8ee3fc6841b359d9597ca0f3c3f159e888d026 /meta/recipes-core/packagegroups/packagegroup-base.bb
parent30aaada4b79fc1acad5fdaba98071b63c52b9e05 (diff)
downloadopenembedded-core-contrib-a56aed2e6e1b73bffd2bf82145fe48b82fde9292.tar.gz
packagegroup: Move inherit packagegroup to after PACKAGE_ARCH
This means these classes now avoid the allarch inherit entirely. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-base.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-base.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-base.bb b/meta/recipes-core/packagegroups/packagegroup-base.bb
index 13a4fe4f0c..f4b2cd574d 100644
--- a/meta/recipes-core/packagegroups/packagegroup-base.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-base.bb
@@ -2,6 +2,11 @@ SUMMARY = "Merge machine and distro options to create a basic machine task/packa
LICENSE = "MIT"
PR = "r83"
+#
+# packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
+#
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
inherit packagegroup
PROVIDES = "${PACKAGES}"
@@ -39,11 +44,6 @@ PACKAGES = ' \
\
'
-#
-# packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
-#
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
# Override by distro if needed
VIRTUAL-RUNTIME_keymaps ?= "keymaps"