summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/newlib/newlib_3.3.0.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro@enedino.org>2020-04-27 15:23:32 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-29 15:00:36 +0100
commitd73aa359e42e707dbc7cfa29c55a2fc8e6bb938a (patch)
treef5289d88f04b4033b3ae6dde1032d33be59dcf43 /meta/recipes-core/newlib/newlib_3.3.0.bb
parent76001bd4ae1e4f153f3d670b19e9ccd39c9fc4ef (diff)
downloadopenembedded-core-contrib-d73aa359e42e707dbc7cfa29c55a2fc8e6bb938a.tar.gz
newlib: Upgrade to latest yearly release 3.3.0
Upgrade to the latest snapshot, also drop md5sum while were at it. Signed-off-by: Alejandro Hernandez Samaniego <alhe@linux.microsoft.com> Signed-off-by: Alejandro Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/newlib/newlib_3.3.0.bb')
-rw-r--r--meta/recipes-core/newlib/newlib_3.3.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-core/newlib/newlib_3.3.0.bb b/meta/recipes-core/newlib/newlib_3.3.0.bb
new file mode 100644
index 0000000000..7ab5b2b94e
--- /dev/null
+++ b/meta/recipes-core/newlib/newlib_3.3.0.bb
@@ -0,0 +1,20 @@
+require newlib.inc
+
+PROVIDES += "virtual/libc virtual/libiconv virtual/libintl"
+
+do_configure() {
+ export CC_FOR_TARGET="${CC}"
+ ${S}/configure ${EXTRA_OECONF}
+}
+
+do_install_append() {
+ # Move include files and libs to default directories so they can be picked up later
+ mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
+ mv -v ${D}${prefix}/${TARGET_SYS}/include ${D}${includedir}
+
+ # Remove original directory
+ rmdir ${D}${prefix}/${TARGET_SYS}
+}
+
+# No rpm package is actually created but -dev depends on it, avoid dnf error
+RDEPENDS_${PN}-dev_libc-newlib = ""