summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/newlib/newlib_3.2.0.bb
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandro@enedino.org>2020-01-15 09:11:46 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-19 13:24:31 +0000
commite2d0e36234ba928d0cbcc98d8358b94d8d44412e (patch)
treede421c07e04c4fda6b31b6da87188305f87d3dde /meta/recipes-core/newlib/newlib_3.2.0.bb
parent9e21387ba2bd04ca844481e42a5999e1d748c730 (diff)
downloadopenembedded-core-contrib-e2d0e36234ba928d0cbcc98d8358b94d8d44412e.tar.gz
newlib: Upgrade newlib and libgloss to the yearly release 3.2.0
A new yearly snapshot was taken on January 2nd of 2020, this bumps newlib to 3.2.0. - Mentor Graphics added tcl license (amdgcn-* targets) - BSD-Clause-2 was added as well by Dinux (pru-* targets) Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/newlib/newlib_3.2.0.bb')
-rw-r--r--meta/recipes-core/newlib/newlib_3.2.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-core/newlib/newlib_3.2.0.bb b/meta/recipes-core/newlib/newlib_3.2.0.bb
new file mode 100644
index 0000000000..7ab5b2b94e
--- /dev/null
+++ b/meta/recipes-core/newlib/newlib_3.2.0.bb
@@ -0,0 +1,20 @@
+require newlib.inc
+
+PROVIDES += "virtual/libc virtual/libiconv virtual/libintl"
+
+do_configure() {
+ export CC_FOR_TARGET="${CC}"
+ ${S}/configure ${EXTRA_OECONF}
+}
+
+do_install_append() {
+ # Move include files and libs to default directories so they can be picked up later
+ mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
+ mv -v ${D}${prefix}/${TARGET_SYS}/include ${D}${includedir}
+
+ # Remove original directory
+ rmdir ${D}${prefix}/${TARGET_SYS}
+}
+
+# No rpm package is actually created but -dev depends on it, avoid dnf error
+RDEPENDS_${PN}-dev_libc-newlib = ""