summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/newlib/newlib_3.0.0.bb
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandr@xilinx.com>2018-03-26 17:20:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 08:54:15 +0100
commitfe490ff829440b94124317759d856e2e2daf5047 (patch)
treebdef2b03e3bcbd70142c71b388592da1e367437f /meta/recipes-core/newlib/newlib_3.0.0.bb
parentcec85a6fcadc24fd266fa34631cb095e0a773c1a (diff)
downloadopenembedded-core-contrib-fe490ff829440b94124317759d856e2e2daf5047.tar.gz
newlib: Adds newlib and libgloss recipes
Newlib is a C library that is intended to be used on embedded systems. It is a conglomeration of several library parts, all under free software licenses that make them easily usable on embedded products. Newlib provides a C library alternative that can run on baremetal, mainly for resource constrained devices. Libgloss is the BSP part of the C library, which can be easily modified to port for new hardware platforms. Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandr@xilinx.com>
Diffstat (limited to 'meta/recipes-core/newlib/newlib_3.0.0.bb')
-rw-r--r--meta/recipes-core/newlib/newlib_3.0.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-core/newlib/newlib_3.0.0.bb b/meta/recipes-core/newlib/newlib_3.0.0.bb
new file mode 100644
index 0000000000..3380576b83
--- /dev/null
+++ b/meta/recipes-core/newlib/newlib_3.0.0.bb
@@ -0,0 +1,16 @@
+require newlib.inc
+
+PROVIDES += "virtual/libc virtual/${TARGET_PREFIX}libc-for-gcc virtual/libiconv virtual/libintl"
+
+do_configure() {
+ ${S}/configure ${EXTRA_OECONF}
+}
+
+do_install_append() {
+ # Move include files and libs to default directories so they can be picked up later
+ mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
+ mv -v ${D}${prefix}/${TARGET_SYS}/include ${D}${includedir}
+
+ # Remove original directory
+ rmdir ${D}${prefix}/${TARGET_SYS}
+}