aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2014-11-10 20:09:29 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-12 15:36:13 +0000
commit1f05aaa4944ddac6c2b3ba440effdf1eaf732656 (patch)
tree1c84f99f0ed93f9765a1101a5017490cc6ce7b8b /meta/recipes-core/meta
parent3562603044e908aacece86985bc8e4d7338622ac (diff)
downloadopenembedded-core-contrib-1f05aaa4944ddac6c2b3ba440effdf1eaf732656.tar.gz
meta-environment: Fix config-site with a multilib config
[YOCTO #6951] The TOOLCHAIN_CONFIGSITE_SYSROOTCACHE value was defaulting to the nativesdk path and not the associated target path. Set the value in toolchain-scripts to the target path. Be sure to set the MLPREFIX within the meta-environment script as multilibs are processed. Update the config_site file name to use -BPN- not PN. Otherwise the environment processing can't find the correct filename. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/meta-environment.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/meta-environment.bb b/meta/recipes-core/meta/meta-environment.bb
index 9d8bcb71de..bb208a39aa 100644
--- a/meta/recipes-core/meta/meta-environment.bb
+++ b/meta/recipes-core/meta/meta-environment.bb
@@ -42,6 +42,7 @@ python do_generate_content() {
# Load overrides from 'd' to avoid having to reset the value...
overrides = d.getVar("OVERRIDES", False) + ":virtclass-multilib-" + item
localdata.setVar("OVERRIDES", overrides)
+ localdata.setVar("MLPREFIX", item + "-")
bb.data.update_data(localdata)
bb.build.exec_func("create_sdk_files", localdata)
}