aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-01-27 11:13:46 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-03 16:14:35 +0000
commitc924d878b55cce7a0e98dc60acf706b5a1b4f404 (patch)
treeec5e3aa68e2407543a35ee6647fcfa06c757f84a /meta/recipes-core/meta
parenta37298eb3421a44e88ec5a66b2fc5305ab18f453 (diff)
downloadopenembedded-core-contrib-c924d878b55cce7a0e98dc60acf706b5a1b4f404.tar.gz
external-csl-toolchain: support ia32
Unfortunately, the CSL ia32 toolchain has non-prefixed binaries in its bindir (e.g. gcc, ld). To avoid this messing up our build, we avoid adding this bindir to our PATH, and instead add symlinks to the prefixed binaries to our staging toolchain bindir. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/external-csl-toolchain.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/external-csl-toolchain.bb b/meta/recipes-core/meta/external-csl-toolchain.bb
index 37ea271eb1..a866e3e3dd 100644
--- a/meta/recipes-core/meta/external-csl-toolchain.bb
+++ b/meta/recipes-core/meta/external-csl-toolchain.bb
@@ -60,6 +60,11 @@ external_toolchain_sysroot_adjust() {
rm -f ${SYSROOT_DESTDIR}/${CSL_TARGET_CORE}
ln -s . ${SYSROOT_DESTDIR}/${CSL_TARGET_CORE}
fi
+
+ if [ "${TUNE_PKGARCH}" = "i586" ]; then
+ rm -f ${SYSROOT_DESTDIR}/system32
+ ln -s . ${SYSROOT_DESTDIR}/system32
+ fi
}
GLIBC_INTERNAL_USE_BINARY_LOCALE ?= "compile"