aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-02-06 14:07:15 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-08 10:42:40 +0000
commitb6ddd434c47c66fdd6dd27a31e545f46b52bc90f (patch)
tree42fe6faa1be7ec95f9ff034d6d36895bd851f35b /meta/recipes-core/meta
parent25d22bfb0970f7152b678796f2282dced7230fe1 (diff)
downloadopenembedded-core-contrib-b6ddd434c47c66fdd6dd27a31e545f46b52bc90f.tar.gz
external-csl-toolchain: split out gdbserver packages
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/external-csl-toolchain.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/external-csl-toolchain.bb b/meta/recipes-core/meta/external-csl-toolchain.bb
index fc35acbb93..22aa99657f 100644
--- a/meta/recipes-core/meta/external-csl-toolchain.bb
+++ b/meta/recipes-core/meta/external-csl-toolchain.bb
@@ -64,6 +64,7 @@ do_install() {
install -d ${D}${bindir}/.debug
mv ${D}${libdir}/bin/.debug/* ${D}${bindir}/.debug/
fi
+ ln -s ../../bin/gdbserver ${D}${libdir}/bin/sysroot-gdbserver
sed -i -e "s# /lib# ../../lib#g" -e "s# /usr/lib# .#g" ${D}${libdir}/libc.so
sed -i -e "s# /lib# ../../lib#g" -e "s# /usr/lib# .#g" ${D}${libdir}/libpthread.so
@@ -86,7 +87,7 @@ external_toolchain_sysroot_adjust() {
fi
}
-PACKAGES =+ "libgcc libgcc-dev libstdc++ libstdc++-dev linux-libc-headers linux-libc-headers-dev"
+PACKAGES =+ "libgcc libgcc-dev libstdc++ libstdc++-dev linux-libc-headers linux-libc-headers-dev gdbserver gdbserver-dbg"
INSANE_SKIP_libgcc = "1"
INSANE_SKIP_libstdc++ = "1"
@@ -126,7 +127,8 @@ PKGV_libstdc++ = "${CSL_VER_GCC}"
PKGV_libstdc++-dev = "${CSL_VER_GCC}"
PKGV_linux-libc-headers = "${CSL_VER_KERNEL}"
PKGV_linux-libc-headers-dev = "${CSL_VER_KERNEL}"
-PKGV_gdbserver = "${CSL_VER_GDBSERVER}"
+PKGV_gdbserver = "${CSL_VER_GDB}"
+PKGV_gdbserver-dbg = "${CSL_VER_GDB}"
FILES_libgcc = "${base_libdir}/libgcc_s.so.1"
FILES_libgcc-dev = "${base_libdir}/libgcc_s.so"
@@ -145,3 +147,5 @@ FILES_linux-libc-headers = "${includedir}/asm* \
${includedir}/sound \
${includedir}/video \
"
+FILES_gdbserver = "${bindir}/gdbserver ${libdir}/bin/sysroot-gdbserver"
+FILES_gdbserver-dbg = "${bindir}/.debug/gdbserver"