aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-01-27 11:13:43 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-01 15:27:06 +0000
commit8fb1c84f4cadf8d7a061fd6d90d270c19b474bfe (patch)
treebc9fcfe91767f19b9caf2d2036370110e2d4a757 /meta/recipes-core/meta
parent73ff2f404392a6942ec89af15ec7f52fe2e629a6 (diff)
downloadopenembedded-core-contrib-8fb1c84f4cadf8d7a061fd6d90d270c19b474bfe.tar.gz
external-csl-toolchain: fixes for metadata changes
These allow the recipe to build again: - add compilerlibs, g++, libgcc to the provides - add linux-libc-headers-dev to the packages - in libc-package, only sed the ldd.bash.in file if it exists, as the external toolchain is using that class as well - shift the inherit location of the libc classes, as they were overriding the recipe's do_install - use ?= for EXTERNAL_TOOLCHAIN, so the user can set it Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/external-csl-toolchain_2008q3-72.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta/recipes-core/meta/external-csl-toolchain_2008q3-72.bb b/meta/recipes-core/meta/external-csl-toolchain_2008q3-72.bb
index a874c8b15a..b5a3607657 100644
--- a/meta/recipes-core/meta/external-csl-toolchain_2008q3-72.bb
+++ b/meta/recipes-core/meta/external-csl-toolchain_2008q3-72.bb
@@ -1,7 +1,12 @@
+inherit libc-common
+inherit libc-package
+
INHIBIT_DEFAULT_DEPS = "1"
# License applies to this recipe code, not the toolchain itself
LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PROVIDES = "\
linux-libc-headers \
@@ -11,21 +16,22 @@ PROVIDES = "\
virtual/arm-none-linux-gnueabi-gcc-intermediate \
virtual/arm-none-linux-gnueabi-binutils \
virtual/arm-none-linux-gnueabi-libc-for-gcc \
+ virtual/arm-none-linux-gnueabi-compilerlibs \
virtual/libc \
virtual/libintl \
virtual/libiconv \
glibc-thread-db \
+ libgcc \
virtual/linux-libc-headers "
RPROVIDES = "glibc-utils libsegfault glibc-thread-db"
PACKAGES_DYNAMIC = "glibc-gconv-*"
-PR = "r1"
+PR = "r2"
#SRC_URI = "http://www.codesourcery.com/public/gnu_toolchain/arm-none-linux-gnueabi/arm-${PV}-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2"
SRC_URI = "file://SUPPORTED"
do_install() {
- echo "EXTERNAL_TOOLCHAIN is ${EXTERNAL_TOOLCHAIN}"
install -d ${D}${sysconfdir} ${D}${bindir} ${D}${sbindir} ${D}${base_bindir} ${D}${libdir}
install -d ${D}${base_libdir} ${D}${base_sbindir} ${D}${datadir}
@@ -40,10 +46,7 @@ do_install() {
GLIBC_INTERNAL_USE_BINARY_LOCALE ?= "compile"
-inherit libc-common
-inherit libc-package
-
-PACKAGES += "libgcc libgcc-dev libstdc++ libstdc++-dev linux-libc-headers"
+PACKAGES += "libgcc libgcc-dev libstdc++ libstdc++-dev linux-libc-headers linux-libc-headers-dev"
FILES_libgcc = "${base_libdir}/libgcc_s.so.1"
FILES_libgcc-dev = "${base_libdir}/libgcc_s.so"
FILES_libstdc++ = "${libdir}/libstdc++.so.*"
@@ -61,4 +64,3 @@ FILES_linux-libc-headers = "${includedir}/asm* \
${includedir}/sound \
${includedir}/video \
"
-