aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-08-22 20:54:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-23 17:22:16 +0100
commit161043782682cccd2efc2b349e8248ae084857c7 (patch)
tree91df0740502087f5949a886722562e73116ff496 /meta/recipes-core/meta
parentf3e2ccff952f148522a09c09e0dea92e59bab5b6 (diff)
downloadopenembedded-core-contrib-161043782682cccd2efc2b349e8248ae084857c7.tar.gz
external-python-tarball: Blacklist recipe if ipk is not in the PACKAGE_CLASSES list
This is needed because ipk tools and variables (specically IPKGCONF_TARGET and IPKGCONF_SDK) are used from the rootfs_ipk.bbclass I tried to inherit directly but it still fails to expand those. [YOCTO #2814] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/external-python-tarball.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/external-python-tarball.bb b/meta/recipes-core/meta/external-python-tarball.bb
index 6bc837b8ce..e317ba32ca 100644
--- a/meta/recipes-core/meta/external-python-tarball.bb
+++ b/meta/recipes-core/meta/external-python-tarball.bb
@@ -5,6 +5,8 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
DEPENDS = "opkg-native opkg-utils-native virtual/fakeroot-native sed-native"
+PR = "r1"
+
inherit meta
SDK_DIR = "${WORKDIR}/sdk"
@@ -91,3 +93,6 @@ do_populate_sdk[nostamp] = "1"
do_populate_sdk[recrdeptask] = "do_package_write"
addtask populate_sdk before do_build after do_install
+inherit blacklist
+
+PNBLACKLIST[external-python-tarball] = "${@base_contains('PACKAGE_CLASSES', 'package_ipk', '', 'This recipe requires \'package_ipk\' support to be enabled in PACKAGE_CLASSES.', d)}"