aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/uninative-tarball.bb
diff options
context:
space:
mode:
authorTyler Hall <tylerwhall@gmail.com>2015-03-24 18:17:10 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-24 22:51:10 +0000
commit0631c2b52432ddf86292351d605b65941d2a8be2 (patch)
treede46808b33486a7e0f5294539a793add764ab499 /meta/recipes-core/meta/uninative-tarball.bb
parentaabd47e46a31b526ee880dfd22a1a1f2831ab355 (diff)
downloadopenembedded-core-contrib-0631c2b52432ddf86292351d605b65941d2a8be2.tar.gz
uninative-tarball: fix dependency on patchelf
DEPENDS doesn't actually add the dependency on patchelf-native to the populate_sdk task. SDK_DEPENDS does this, but move the append to after inheriting the base class so it does not get overwritten. Without this, uninative-tarball fails to build in a clean workspace on a system without patchelf. [YOCTO #7467] Signed-off-by: Tyler Hall <tylerwhall@gmail.com> Acked-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/uninative-tarball.bb')
-rw-r--r--meta/recipes-core/meta/uninative-tarball.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/meta/uninative-tarball.bb b/meta/recipes-core/meta/uninative-tarball.bb
index 53435f22ae..62bdde85fc 100644
--- a/meta/recipes-core/meta/uninative-tarball.bb
+++ b/meta/recipes-core/meta/uninative-tarball.bb
@@ -11,7 +11,6 @@ TOOLCHAIN_HOST_TASK = "\
"
INHIBIT_DEFAULT_DEPS = "1"
-DEPENDS += "patchelf-native"
TOOLCHAIN_OUTPUTNAME ?= "${BUILD_ARCH}-nativesdk-libc"
@@ -25,6 +24,8 @@ inherit populate_sdk
deltask install
deltask package
+SDK_DEPENDS += "patchelf-native"
+
SDK_PACKAGING_FUNC = ""
fakeroot create_sdk_files() {