aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-12-05 18:09:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-19 17:54:14 +0000
commit5b051d65e797624cca3a81fc6f5c924925f3493e (patch)
tree0dda39eb50731ed3b130fd57eaa32a738e5e7b74 /meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
parent90904ef3bab182a46174f7bb60e83f0f22a3f209 (diff)
downloadopenembedded-core-contrib-5b051d65e797624cca3a81fc6f5c924925f3493e.tar.gz
buildtools-tarball: restore missing git tools
Since the split out of git-perltools, some git tools (such as "git am", "git send-email" and "git-submodule") have no longer been part of the buildtools. We need these, so add them back in. However, adding git-perltools to buildtools triggers perl itself being brought into buildtools as well, and we don't want that; but we also don't want to have to hack the git recipe or indeed anything else that starts depending on perl. Thus, add a dummy package which gets installed in its place, in a separate package architecture that is only enabled for buildtools to ensure it doesn't start appearing in place of nativesdk-perl anywhere else. Fixes [YOCTO #7033]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb')
-rw-r--r--meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
new file mode 100644
index 0000000000..d971c3ca3d
--- /dev/null
+++ b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Dummy package which ensures perl is excluded from buildtools"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit nativesdk
+
+# Put it somewhere separate to ensure it's never used except when we want it
+PACKAGE_ARCH = "buildtools-dummy-${SDKPKGSUFFIX}"
+
+PERLPACKAGES = "nativesdk-perl \
+ nativesdk-perl-module-file-path"
+
+ALLOW_EMPTY_${PN} = "1"
+
+python populate_packages_prepend() {
+ d.appendVar('RPROVIDES_${PN}', '${PERLPACKAGES}')
+ d.appendVar('RCONFLICTS_${PN}', '${PERLPACKAGES}')
+}
+