aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2016-02-11 16:08:06 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-11 22:33:21 +0000
commitcb7a3f997d7278eb6e31ea79ad933a7ab1717977 (patch)
tree9f9868ef9e926935700daff91b86818c589c1f09 /meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
parent32611395e1da21f6f7f7916fb8077e35ee81bb23 (diff)
downloadopenembedded-core-contrib-cb7a3f997d7278eb6e31ea79ad933a7ab1717977.tar.gz
openembedded-core-contrib-cb7a3f997d7278eb6e31ea79ad933a7ab1717977.tar.bz2
openembedded-core-contrib-cb7a3f997d7278eb6e31ea79ad933a7ab1717977.zip
nativesdk-buildtools-perl-dummy.bb: Fix variable expansion in python code
Since python expansion of bb data variables is disable in order to provide a standard interface usage for expand variables this variables aren't expanded now so change to call d.expand('${VAR}'). This API expansion change was causing to install perl in nativesdk. Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb')
-rw-r--r--meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
index 9041734898..90784a9e27 100644
--- a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
+++ b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
@@ -20,7 +20,7 @@ PERLPACKAGES = "nativesdk-perl \
ALLOW_EMPTY_${PN} = "1"
python populate_packages_prepend() {
- d.appendVar('RPROVIDES_${PN}', '${PERLPACKAGES}')
- d.appendVar('RCONFLICTS_${PN}', '${PERLPACKAGES}')
+ d.appendVar(d.expand('RPROVIDES_${PN}'), '${PERLPACKAGES}')
+ d.appendVar(d.expand('RCONFLICTS_${PN}'), '${PERLPACKAGES}')
}