summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/cve-update-db-native.bb
diff options
context:
space:
mode:
authorMarta Rybczynska <rybczynska@gmail.com>2022-05-02 16:25:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-03 17:49:31 +0100
commit35bccdedadeaba820d58b69fe74ce5e4c1f577e3 (patch)
tree72b5c1c97f4bcd4e23ba1871d3b7b0af0cd1a084 /meta/recipes-core/meta/cve-update-db-native.bb
parent3a43c2a82881688d85238464db371f695e60b572 (diff)
downloadopenembedded-core-contrib-35bccdedadeaba820d58b69fe74ce5e4c1f577e3.tar.gz
cve-update-db-native: update the CVE database once a day only
The update of the NVD database was expected to happen once per hour. However, the database file date changes only if the content was actually updated. In practice, the check worked for the first hour after the new download. As the NVD database changes usually only once a day, we can just update it less frequently. Signed-off-by: Marta Rybczynska <marta.rybczynska@huawei.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/cve-update-db-native.bb')
-rw-r--r--meta/recipes-core/meta/cve-update-db-native.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/cve-update-db-native.bb b/meta/recipes-core/meta/cve-update-db-native.bb
index e5822cee58..af39480dda 100644
--- a/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/meta/recipes-core/meta/cve-update-db-native.bb
@@ -43,10 +43,10 @@ python do_fetch() {
if os.path.exists(db_file):
os.remove(db_file)
- # Don't refresh the database more than once an hour
+ # The NVD database changes once a day, so no need to update more frequently
try:
import time
- if time.time() - os.path.getmtime(db_file) < (60*60):
+ if time.time() - os.path.getmtime(db_file) < (24*60*60):
bb.debug(2, "Recently updated, skipping")
return
except OSError: