aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/buildtools-extended-tarball.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-12-22 17:18:37 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-08 14:39:02 +0100
commit4b23c235bdf29cc45ab084e6fdce8cba3ce7fce2 (patch)
tree5b24729945fb9810df45b88de9694bea265436f9 /meta/recipes-core/meta/buildtools-extended-tarball.bb
parent669b73c9f469642085c6ad11b55a9065c889ddbd (diff)
downloadopenembedded-core-contrib-4b23c235bdf29cc45ab084e6fdce8cba3ce7fce2.tar.gz
buildtools-extended-tarball: add recipe with build-essentials
* For some aging distros, such as CentOS 7, the native version of gcc is simply too ancient and is a constant source of headaches for moving forward. * Add an extended version of buildtools-tarball which adds all of build-essential, so that the host is now modernized and capable of compiling the latest versions of components. Fixes [YOCTO #13714] (From OE-Core rev: f0377af2325613b63716b0bb4db1ab253d79f388) (From OE-Core rev: bb4979f0e8367b475cc9a5274933a61bb0eb64b3) (From OE-Core rev: f492e172e133a4b52dbe818d806cab783204e575) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/buildtools-extended-tarball.bb')
-rw-r--r--meta/recipes-core/meta/buildtools-extended-tarball.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/buildtools-extended-tarball.bb b/meta/recipes-core/meta/buildtools-extended-tarball.bb
new file mode 100644
index 0000000000..d756036373
--- /dev/null
+++ b/meta/recipes-core/meta/buildtools-extended-tarball.bb
@@ -0,0 +1,32 @@
+require recipes-core/meta/buildtools-tarball.bb
+
+DESCRIPTION = "SDK type target for building a standalone tarball containing build-essentials, python3, chrpath, \
+ make, git and tar. The tarball can be used to run bitbake builds on systems which don't meet the \
+ usual version requirements and have ancient compilers."
+SUMMARY = "Standalone tarball for running builds on systems with inadequate software and ancient compilers"
+LICENSE = "MIT"
+
+# Add nativesdk equivalent of build-essentials
+TOOLCHAIN_HOST_TASK += "\
+ nativesdk-automake \
+ nativesdk-autoconf \
+ nativesdk-binutils \
+ nativesdk-binutils-symlinks \
+ nativesdk-cpp \
+ nativesdk-cpp-symlinks \
+ nativesdk-gcc \
+ nativesdk-gcc-symlinks \
+ nativesdk-g++ \
+ nativesdk-g++-symlinks \
+ nativesdk-gettext \
+ nativesdk-libatomic \
+ nativesdk-libgcc \
+ nativesdk-libstdc++ \
+ nativesdk-libstdc++-dev \
+ nativesdk-libtool \
+ nativesdk-pkgconfig \
+ "
+
+TOOLCHAIN_OUTPUTNAME = "${SDK_ARCH}-buildtools-extended-nativesdk-standalone-${DISTRO_VERSION}"
+
+SDK_TITLE = "Extended Build tools"