aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxml/libxml2.inc
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-09-08 20:24:38 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:11 +0100
commited72e123724599e70eb4d283f06fca3e56a8b50a (patch)
treec3120e7f3233a362bffd6418a05ea8802ea03764 /meta/recipes-core/libxml/libxml2.inc
parentf049a53078b3876be9fefc1e5f64404a3f378724 (diff)
downloadopenembedded-core-contrib-ed72e123724599e70eb4d283f06fca3e56a8b50a.tar.gz
libxml2: fix python path and add libxml2-python
We have libxml2-python for native and nativesdk, but don't have it for target, and can't find the reason from the git log, libxml2-python is widely used, after looked into it's configure.in, we can add it by PACKAGECONFIG. The previous --with-python=${STAGING_BINDIR}/python is incorrect, it acted as work becase it's conigure can check automatically, python is in ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN}, as known as ${PYTHON}. Add python to PACKAGECONFIG, since createrepo rdepends on libxml2-python, otherwise the target createrepo can't work. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-core/libxml/libxml2.inc')
-rw-r--r--meta/recipes-core/libxml/libxml2.inc20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-core/libxml/libxml2.inc b/meta/recipes-core/libxml/libxml2.inc
index 1314bbfb8d..d337bec0d0 100644
--- a/meta/recipes-core/libxml/libxml2.inc
+++ b/meta/recipes-core/libxml/libxml2.inc
@@ -9,8 +9,6 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
-DEPENDS_class-nativesdk = "nativesdk-python"
-DEPENDS_class-native = "python-native"
DEPENDS =+ "zlib"
SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz;name=libtar \
@@ -30,6 +28,8 @@ inherit autotools pkgconfig binconfig-disabled pythonnative ptest
RDEPENDS_${PN}-ptest += "python-core"
+RDEPENDS_${PN}-python += "python-core"
+
RDEPENDS_${PN}-ptest_append_libc-glibc += "glibc-gconv-ebcdic-us glibc-gconv-ibm1141"
# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
@@ -37,16 +37,16 @@ do_configure_prepend () {
sed -i -e '/.*ansidecl.h.*/d' ${S}/configure.ac
}
-do_configure_prepend_class-nativesdk () {
- # Ensure we get the correct site-packages path
- export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
-}
+export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
+
+PACKAGECONFIG ??= "python"
+PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python"
# WARNING: zlib is require for RPM use
-EXTRA_OECONF = "--without-python --without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
-EXTRA_OECONF_class-native = "--with-python=${STAGING_BINDIR}/python --without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
-EXTRA_OECONF_class-nativesdk = "--with-python=${STAGING_BINDIR}/python --without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
-EXTRA_OECONF_linuxstdbase = "--without-python --with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
+EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
+EXTRA_OECONF_class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
+EXTRA_OECONF_class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
+EXTRA_OECONF_linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
# required for pythong binding
export HOST_SYS