aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/kbd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-11-07 05:35:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-08 17:31:17 +0000
commiteac8cb7cacab7f2fb392128aa5ebc2046ca4a793 (patch)
tree95e7a6203ef54c193fcc2d08d92598babae0332b /meta/recipes-core/kbd
parent4b2aa17a5c5d2ccf9824a4d2fd71f600b18ba2f2 (diff)
downloadopenembedded-core-contrib-eac8cb7cacab7f2fb392128aa5ebc2046ca4a793.tar.gz
kbd: Fix stdarg related errors on uclibc
It does not get stdarg.h included indirectly as it happens on uclibc due to different include chain Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/kbd')
-rw-r--r--meta/recipes-core/kbd/kbd/uclibc-stdarg.patch36
-rw-r--r--meta/recipes-core/kbd/kbd_2.0.1.bb4
2 files changed, 39 insertions, 1 deletions
diff --git a/meta/recipes-core/kbd/kbd/uclibc-stdarg.patch b/meta/recipes-core/kbd/kbd/uclibc-stdarg.patch
new file mode 100644
index 0000000000..be7f324acc
--- /dev/null
+++ b/meta/recipes-core/kbd/kbd/uclibc-stdarg.patch
@@ -0,0 +1,36 @@
+In file included from keymap.h:5:0,
+ from ksyms.c:6:
+./keymap/common.h:65:38: error: unknown type name 'va_list'
+ const char *format, va_list args),
+ ^
+./keymap/common.h:66:3: error: expected ';', ',' or ')' before 'const'
+ const void *data);
+ ^
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Index: kbd-2.0.0/src/libkeymap/contextP.h
+===================================================================
+--- kbd-2.0.0.orig/src/libkeymap/contextP.h 2013-08-13 06:46:23.000000000 -0700
++++ kbd-2.0.0/src/libkeymap/contextP.h 2013-11-05 22:33:49.200528226 -0800
+@@ -2,7 +2,7 @@
+ #define LK_CONTEXTP_H
+
+ #include "keymap.h"
+-
++#include <stdarg.h>
+ /**
+ * @brief Copy of struct kbdiacruc.
+ */
+Index: kbd-2.0.0/src/libkeymap/keymap/common.h
+===================================================================
+--- kbd-2.0.0.orig/src/libkeymap/keymap/common.h 2013-08-13 06:46:23.000000000 -0700
++++ kbd-2.0.0/src/libkeymap/keymap/common.h 2013-11-05 22:33:59.964528438 -0800
+@@ -6,6 +6,7 @@
+ */
+
+ #include <keymap/context.h>
++#include <stdarg.h>
+
+ /** Initializes the structures necessary to read and/or parse keymap.
+ *
diff --git a/meta/recipes-core/kbd/kbd_2.0.1.bb b/meta/recipes-core/kbd/kbd_2.0.1.bb
index d39f4c8f32..b2afc602a1 100644
--- a/meta/recipes-core/kbd/kbd_2.0.1.bb
+++ b/meta/recipes-core/kbd/kbd_2.0.1.bb
@@ -10,7 +10,9 @@ RREPLACES_${PN} = "console-tools"
RPROVIDES_${PN} = "console-tools"
RCONFLICTS_${PN} = "console-tools"
-SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.bz2"
+SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.bz2 \
+ file://uclibc-stdarg.patch \
+ "
SRC_URI[md5sum] = "f80b93a6abddb6cc2a3652daaf7562ba"
SRC_URI[sha256sum] = "223d60bb6882323cca161aeb5965590768b2f590fd7cddbf27511ad0ba7a429e"