aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/kbd/kbd_2.0.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-14 13:26:29 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-16 12:11:25 +0000
commit3232c56c01631953445429d1eb7ab532404d6271 (patch)
tree6400e9b25673ea4fbe6fbc947eb7bfdef3aa164a /meta/recipes-core/kbd/kbd_2.0.3.bb
parent8b21d3b32f8ac4cc4b3ebea1db2b13df0dec1c3b (diff)
downloadopenembedded-core-contrib-3232c56c01631953445429d1eb7ab532404d6271.tar.gz
kbd: update to 2.0.3
0003-Only-inluclude-kernel-headers-with-glibc.patch is handling #include lines that are no longer present in the upstream source so it was dropped. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/kbd/kbd_2.0.3.bb')
-rw-r--r--meta/recipes-core/kbd/kbd_2.0.3.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-core/kbd/kbd_2.0.3.bb b/meta/recipes-core/kbd/kbd_2.0.3.bb
new file mode 100644
index 0000000000..746b68adee
--- /dev/null
+++ b/meta/recipes-core/kbd/kbd_2.0.3.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Keytable files and keyboard utilities"
+# everything minus console-fonts is GPLv2+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a5fcc36121d93e1f69d96a313078c8b5"
+DEPENDS = "libcheck"
+
+inherit autotools gettext ptest pkgconfig
+
+RREPLACES_${PN} = "console-tools"
+RPROVIDES_${PN} = "console-tools"
+RCONFLICTS_${PN} = "console-tools"
+
+SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
+ file://uclibc-stdarg.patch \
+ "
+
+SRC_URI[md5sum] = "231b46e7142eb41ea3ae06d2ded3c208"
+SRC_URI[sha256sum] = "7a899de1c0eb75f3aea737095a736f2375e1cbfbe693fc14a3fe0bfb4649fb5e"
+
+PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
+PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
+
+PACKAGES += "${PN}-consolefonts ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
+
+FILES_${PN}-consolefonts = "${datadir}/consolefonts"
+FILES_${PN}-consoletrans = "${datadir}/consoletrans"
+FILES_${PN}-keymaps = "${datadir}/keymaps"
+FILES_${PN}-unimaps = "${datadir}/unimaps"
+
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "chvt deallocvt fgconsole openvt"
+ALTERNATIVE_PRIORITY = "100"
+
+BBCLASSEXTEND = "native"
+PARALLEL_MAKEINST = ""