aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/initrdscripts/files/init-live.sh
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-07-03 21:05:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-19 17:48:53 +0100
commit4bce3417917a3e88ba6529db394525fba82e0699 (patch)
tree070dc9a31a17b16381631dd73723c5285666bbf0 /meta/recipes-core/initrdscripts/files/init-live.sh
parent5b7da937cd298abd6f8f0eecfede2810b157179f (diff)
downloadopenembedded-core-contrib-4bce3417917a3e88ba6529db394525fba82e0699.tar.gz
EFI: Make installer EFI aware
[YOCTO #1919] Create a basic EFI installer script modeled after the existing installer and add it to a new initramfs-live-install-efi recipe. Update the init-live.sh script to distinguish between LABEL=install and LABEL=install-efi and select the appropriate script. Add the efi installer to core-image-minimal-initramfs. Update grub-efi.bbclass to use "LABEL=install-efi" when it detects a label of "install". This is clearly not ideal, but a proper fix would involve decoupling the LABELS assignment from the image-live.bbclass usage of SYSLINUX_LABELS. We should be able to address that in a follow-on clean-up series. V2: Include missing initramfs-live-install-efi_1.0.bb V3: Rebase after Radu's console_params fix Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/initrdscripts/files/init-live.sh')
-rw-r--r--meta/recipes-core/initrdscripts/files/init-live.sh6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/initrdscripts/files/init-live.sh b/meta/recipes-core/initrdscripts/files/init-live.sh
index d5e241a620..3fba7dc3a1 100644
--- a/meta/recipes-core/initrdscripts/files/init-live.sh
+++ b/meta/recipes-core/initrdscripts/files/init-live.sh
@@ -116,11 +116,11 @@ case $label in
fi
fi
;;
- install)
+ install|install-efi)
if [ -f /media/$i/$ISOLINUX/$ROOT_IMAGE ] ; then
- ./install.sh $i/$ISOLINUX $ROOT_IMAGE $video_mode $vga_mode $console_params
+ ./$label.sh $i/$ISOLINUX $ROOT_IMAGE $video_mode $vga_mode $console_params
else
- fatal "Could not find install script"
+ fatal "Could not find $label script"
fi
# If we're getting here, we failed...