aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-02-29 23:46:22 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-01 15:40:02 +0000
commit1a3bd2ae195d515fe2c93bc178b45cce8505d831 (patch)
treea6682808c8b754ab8ef77874517baf9f9dd2cae1 /meta/recipes-core/images
parentaa961e112b07d42c272e01f2d69f3c139e9ae70f (diff)
downloadopenembedded-core-contrib-1a3bd2ae195d515fe2c93bc178b45cce8505d831.tar.gz
self-hosted-image: Create a VMDK image with correct SYSLINUX_* settings
Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/images')
-rw-r--r--meta/recipes-core/images/self-hosted-image.bb16
1 files changed, 14 insertions, 2 deletions
diff --git a/meta/recipes-core/images/self-hosted-image.bb b/meta/recipes-core/images/self-hosted-image.bb
index a0a7592091..d56c2cb37f 100644
--- a/meta/recipes-core/images/self-hosted-image.bb
+++ b/meta/recipes-core/images/self-hosted-image.bb
@@ -1,11 +1,23 @@
IMAGE_INSTALL = "task-core-boot task-core-apps-console task-core-ssh-openssh task-self-hosted"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PR = "r5"
+
CORE_IMAGE_EXTRA_INSTALL = "\
task-self-hosted \
"
IMAGE_FEATURES += "x11-mini package-management"
-inherit core-image
+# Ensure there's enough space to do a core-image-minimal build, with rm_work enabled
+IMAGE_ROOTFS_EXTRA_SPACE = "2621440"
-PR = "r2"
+# Do a quiet boot with limited console messages
+APPEND += "quiet"
+
+IMAGE_FSTYPES = "vmdk"
+
+inherit core-image