aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2015-07-01 17:02:22 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-31 15:15:13 +0100
commitda5d21c3a1ae5d4767b803ba05dcce2f1b3d3808 (patch)
tree178e1de7d4a3649556cf38cc6d1d487fb91fa5bf /meta/recipes-core/glibc
parent29086fa030d9283261c5840b7ed8227fb419ac3f (diff)
downloadopenembedded-core-contrib-da5d21c3a1ae5d4767b803ba05dcce2f1b3d3808.tar.gz
glibc: don't override TUNE_CCARGS for MIPS
Overriding TUNE_CCARGS this way breaks MULTILIB setup for MIPS. This override disables multilib handling of tunes for TUNE_CCARGS, thus enforcing glibc's TUNE_CCARGS to the TUNE_CCARGS of main DEFAULTTUNE. Glibc perfectly build without this override for both simple and multilib cases. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb10
1 files changed, 0 insertions, 10 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index 30f19376e8..55424bfaac 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -95,16 +95,6 @@ do_patch_append() {
bb.build.exec_func('do_fix_readlib_c', d)
}
-# for mips glibc now builds syscall tables for all abi's
-# so we make sure that we choose right march option which is
-# compatible with o32,n32 and n64 abi's
-# e.g. -march=mips32 is not compatible with n32 and n64 therefore
-# we filter it out in such case -march=from-abi which will be
-# mips1 when using o32 and mips3 when using n32/n64
-
-TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
-TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
-
do_fix_readlib_c () {
sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
}