aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-23 20:35:19 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-27 14:57:44 +0100
commit6f4be55ca66b4470aa46c0ae356070ed166f44ce (patch)
tree0fcb1948839bc7fec0cfa9be4bf2e279a0ca1906 /meta/recipes-core/glibc
parent0731fb03b5cc40502f90912fb2e72b54b777509d (diff)
downloadopenembedded-core-contrib-6f4be55ca66b4470aa46c0ae356070ed166f44ce.tar.gz
glibc, packagegroup-self-hosted, packagegroup-core-lsb: Consider non-glibc libcs
Make skipping expression simpler to check for given libc Make sure glibc specific items are covered with right override Change-Id: I8b4a0b7cbfe38ffdc9320f798038c79c7220552b Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index fcef4ff3e5..58a9601034 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -68,11 +68,9 @@ GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn
# this helps in easing out parsing for non-glibc system libraries
#
python __anonymous () {
- import re
- notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) or (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
- if notglibc:
- raise bb.parse.SkipPackage("incompatible with target %s" %
- d.getVar('TARGET_OS', True))
+ if d.getVar('TCLIBC', True) != "glibc":
+ raise bb.parse.SkipPackage("incompatible with %s C library" %
+ d.getVar('TCLIBC', True))
}
EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \