aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-20 04:24:36 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-21 22:04:26 +0000
commit5d7bc14d22da87837741fefae5924571fdff750d (patch)
tree7f6b860075a39e615d6f6c9239144f8eb2dcc993 /meta/recipes-core/glibc
parent4ed94affbce657db58c5099c8882a8d0292abaf1 (diff)
downloadopenembedded-core-contrib-5d7bc14d22da87837741fefae5924571fdff750d.tar.gz
glibc: Dont offer to be parsed for non-glibc TCLIBC selection
We now can support musl along with uclibc and glibc earlier when only alternative was uclibc this check was fine but now we need to consider non-glibc vs glibc case instead of uclibc vs glibc Change-Id: Id794ce193c6557b5435002a8f9b6eb608738b696 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb12
1 files changed, 4 insertions, 8 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index 1ef494b086..6e540462cb 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -62,17 +62,13 @@ TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
#
-# For now, we will skip building of a gcc package if it is a uclibc one
-# and our build is not a uclibc one, and we skip a glibc one if our build
-# is a uclibc build.
+# We will skip parsing glibc when system C library selection is not glibc
+# this helps in easing out parsing for non-glibc system libraries
#
-# See the note in gcc/gcc_3.4.0.oe
-#
-
python __anonymous () {
import re
- uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None)
- if uc_os:
+ notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) and (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
+ if notglibc:
raise bb.parse.SkipPackage("incompatible with target %s" %
d.getVar('TARGET_OS', True))
}