summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-23 07:45:32 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-25 22:35:54 +0100
commitf6521f85f783dc7565eb0c0046de59aa945423e5 (patch)
tree76eb77861dbf8f116d0df54a830002a852868721 /meta/recipes-core/glibc
parent1d207eac08d9392b0ae53a2e740aabad72e57750 (diff)
downloadopenembedded-core-contrib-f6521f85f783dc7565eb0c0046de59aa945423e5.tar.gz
glibc: Enable memory tagging for aarch64
Glibc on aarch64 has a memory tagging option that can be enabled via GLIBC_TUNABLES="glibc.mem.tagging=$SOMETHING" when glibc is built with memory tagging support and the kernel/HW supports MTE. There should be no side effects unless the user turns it on with approprate HW support Linux 5.4 headers and binutils 2.33.1 or newer is needed. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/glibc_2.33.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.33.bb b/meta/recipes-core/glibc/glibc_2.33.bb
index 6bdfdfcd4a..b70cd0978a 100644
--- a/meta/recipes-core/glibc/glibc_2.33.bb
+++ b/meta/recipes-core/glibc/glibc_2.33.bb
@@ -90,6 +90,7 @@ EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
EXTRA_OECONF_append_x86 = " --enable-cet"
EXTRA_OECONF_append_x86-64 = " --enable-cet"
+EXTRA_OECONF_append_aarch64 = " --enable-memory-tagging"
PACKAGECONFIG ??= "nscd"
PACKAGECONFIG[nscd] = "--enable-nscd,--disable-nscd"