aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-07-13 03:02:41 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-16 15:09:20 +0100
commitd890d81aa5d6f526a0936db31067d12d32335b75 (patch)
tree6974c8a2f6208a5e78ebea99089efe43d24fb41e /meta/recipes-core/glibc
parent1537381d930fe55ba1f8917d6f5db3ad7c349992 (diff)
downloadopenembedded-core-contrib-d890d81aa5d6f526a0936db31067d12d32335b75.tar.gz
glibc: print PN when bbwarn
The current warning is: WARNING: glibc: unable to generate header for spray.x Which is easier to debug than: WARNING: unable to generate header for spray.x And remove the file before generate it again to fix the warning when recompile: file `bootparam_prot.h' already exists and may be overwritten WARNING: unable to generate header for bootparam_prot.x file `nlm_prot.h' already exists and may be overwritten WARNING: unable to generate header for nlm_prot.x [snip] (From OE-Core rev: 5ae6d368a89d5f7f3c860f80aa8afb689053afd4) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index 8197c29d2e..30f19376e8 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -135,7 +135,8 @@ do_compile () {
cd ${S}/sunrpc/rpcsvc
for r in ${rpcsvc}; do
h=`echo $r|sed -e's,\.x$,.h,'`
- rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
+ rm -f $h
+ rpcgen -h $r -o $h || bbwarn "${PN}: unable to generate header for $r"
done
)
echo "Adjust ldd script"