aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2010-12-29 10:10:15 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-06 10:06:28 +0000
commit656409795206a45284694b2c43d83c1cdccc0c8c (patch)
tree9a0492b03714957be6641251d89de070071cd2d7 /meta/recipes-core/glib-2.0
parent40be3e1e9716a11ca1daffb67f6e5687e4242cd1 (diff)
downloadopenembedded-core-contrib-656409795206a45284694b2c43d83c1cdccc0c8c.tar.gz
glib-2.0: fix g_once_init_enter compile failure
Kernelshark trips over a compile bug in glib-2.0 addressed by Open Embedded back in the 2.22 timeframe. It appears to still be present in 2.27. http://www.mail-archive.com/openembedded-devel@lists.openembedded.org/msg00529.html Signed-off-by: Darren Hart <dvhart@linux.intel.com> CC: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta/recipes-core/glib-2.0')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0-2.27.5/g_once_init_enter.patch22
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.27.5.bb6
2 files changed, 26 insertions, 2 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0-2.27.5/g_once_init_enter.patch b/meta/recipes-core/glib-2.0/glib-2.0-2.27.5/g_once_init_enter.patch
new file mode 100644
index 0000000000..a2a506c2ad
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0-2.27.5/g_once_init_enter.patch
@@ -0,0 +1,22 @@
+fix g_once_init_enter compile failure
+
+Kernelshark trips over a compile bug in glib-2.0 addressed by Open Embedded
+back in the 2.22 timeframe. It appears to still be present in 2.27.
+
+http://www.mail-archive.com/openembedded-devel@lists.openembedded.org/msg005
+
+Signed-off-by: Darren Hart <dvhart@linux.intel.com>
+
+Index: glib-2.27.5/glib/gthread.h
+===================================================================
+--- glib-2.27.5.orig/glib/gthread.h
++++ glib-2.27.5/glib/gthread.h
+@@ -344,7 +344,7 @@ void g_once_init_leav
+ G_INLINE_FUNC gboolean
+ g_once_init_enter (volatile gsize *value_location)
+ {
+- if G_LIKELY ((gpointer) g_atomic_pointer_get (value_location) != NULL)
++ if G_LIKELY ((gpointer) g_atomic_pointer_get ((volatile gpointer *)value_location) != NULL)
+ return FALSE;
+ else
+ return g_once_init_enter_impl (value_location);
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.27.5.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.27.5.bb
index 442738aad3..171c8fe651 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.27.5.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.27.5.bb
@@ -1,10 +1,12 @@
require glib.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/glib/2.27/glib-${PV}.tar.bz2 \
file://configure-libtool.patch \
- file://60_wait-longer-for-threads-to-die.patch"
+ file://60_wait-longer-for-threads-to-die.patch \
+ file://g_once_init_enter.patch \
+ "
SRC_URI[md5sum] = "b7025b581bf78fcd656117bfc113f21f"
SRC_URI[sha256sum] = "aad3038db865b762e01b1dc455ffd601b4083c069018d290e5fdfe1a61d328dc"