summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-10 17:56:16 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-11 15:19:21 +0000
commit83899aad423cd36cea7ab2ea210feae5b3359823 (patch)
treeb01ee119a7606ffae1a2661e05ba0ab3db1059fd /meta/recipes-core/glib-2.0
parente8cfc8525c5d903ee876eafd56521f4a7325a6f5 (diff)
downloadopenembedded-core-contrib-83899aad423cd36cea7ab2ea210feae5b3359823.tar.gz
glib-2.0: Fix hardcoded paths in checksums
The expansion by this function, recently added by the meson site handling code was causing hardcoded paths to become embedded in the tash hashes. Avoid this (and hence avoid eSDK failures which exposed this). Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-2.0')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb
index 953fba501a..5e71c81cca 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb
@@ -29,6 +29,7 @@ def find_meson_cross_files(d):
if bb.data.inherits_class('native', d):
return ""
+ corebase = d.getVar("COREBASE")
import collections
sitedata = siteinfo_data(d)
# filename -> found
@@ -36,7 +37,7 @@ def find_meson_cross_files(d):
for path in d.getVar("FILESPATH").split(":"):
for element in sitedata:
filename = os.path.join(path, "meson.cross.d", element)
- files[filename] = os.path.exists(filename)
+ files[filename.replace(corebase, "${COREBASE}")] = os.path.exists(filename)
items = ["--cross-file=" + k for k,v in files.items() if v]
d.appendVar("EXTRA_OEMESON", " " + " ".join(items))