aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0/glib-2.0
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-07 09:49:43 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-07 10:53:24 +0100
commit2929e7d590862d9649458c90804e79a1dce40423 (patch)
treec78d41629a3dd6e12ed794b4b9cb9c5fccfc6577 /meta/recipes-core/glib-2.0/glib-2.0
parent672846b0262add037daa2c9e434fe09388b58da8 (diff)
downloadopenembedded-core-contrib-2929e7d590862d9649458c90804e79a1dce40423.tar.gz
glib-2.0: Fix issues with libelf dependency creeping in
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-2.0/glib-2.0')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch b/meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch
new file mode 100644
index 0000000000..e9b3b26a27
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch
@@ -0,0 +1,37 @@
+Ideally there would be configureation option for this but there is not. We
+can't allow this code since it could detect the host system's libelf with
+disasterous effects when cross compiling.
+
+RP 2012/5/7
+
+Upstream-Status: Pending (would need to be made a configure option to disabe)
+
+Index: glib-2.32.2/configure.ac
+===================================================================
+--- glib-2.32.2.orig/configure.ac 2012-05-07 08:30:04.481149925 +0000
++++ glib-2.32.2/configure.ac 2012-05-07 08:31:02.185148588 +0000
+@@ -1816,23 +1816,7 @@
+ dnl *** check for libelf ***
+ dnl ************************
+
+-PKG_CHECK_MODULES([LIBELF], [libelf], [have_libelf=yes], [have_libelf=maybe])
+-
+-if test $have_libelf = maybe; then
+- AC_CHECK_LIB([elf], [elf_begin], , [have_libelf=no])
+- AC_CHECK_LIB([elf], [elf_getshdrstrndx], , [have_libelf=no])
+- AC_CHECK_LIB([elf], [elf_getshdrnum], , [have_libelf=no])
+- AC_CHECK_HEADER([libelf.h], , [have_libelf=no])
+-
+- if test $have_libelf != no; then
+- LIBELF_LIBS=-lelf
+- have_libelf = yes
+- fi
+-fi
+-
+-if test $have_libelf = yes; then
+- AC_DEFINE(HAVE_LIBELF, 1, [Define if libelf is available])
+-fi
++have_libelf=no
+
+ dnl ****************************************
+ dnl *** platform dependent source checks ***