aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-12-13 00:48:40 +0100
committerSaul Wold <sgw@linux.intel.com>2012-12-14 15:17:20 -0800
commite60612a9fed96d92c5119ab3b26a355d152db1b8 (patch)
treef1cd4340f3c7e9b956075028561f42029ed34ca4 /meta/recipes-core/gettext
parentc00778dd0d9c3b62657057e92c868ad2257d72d3 (diff)
downloadopenembedded-core-contrib-e60612a9fed96d92c5119ab3b26a355d152db1b8.tar.gz
gettext: move remove-potcdate.sin from gettext-native to gettext-minimal-native
* now autotools.bbclass are copying not only Makefile.in.in but also remove-potcdate.sin which is used by Makefile.in.in, so we need to provide this file already in gettext-minimal-native otherwise build can fail, when autotools.bbclass is used before gettext-native (full) is built. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/gettext')
-rw-r--r--meta/recipes-core/gettext/gettext-minimal-0.18.1.1/remove-potcdate.sin19
-rw-r--r--meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb4
-rw-r--r--meta/recipes-core/gettext/gettext_0.18.1.1.bb3
3 files changed, 24 insertions, 2 deletions
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.18.1.1/remove-potcdate.sin b/meta/recipes-core/gettext/gettext-minimal-0.18.1.1/remove-potcdate.sin
new file mode 100644
index 0000000000..2436c49e78
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-minimal-0.18.1.1/remove-potcdate.sin
@@ -0,0 +1,19 @@
+# Sed script that remove the POT-Creation-Date line in the header entry
+# from a POT file.
+#
+# The distinction between the first and the following occurrences of the
+# pattern is achieved by looking at the hold space.
+/^"POT-Creation-Date: .*"$/{
+x
+# Test if the hold space is empty.
+s/P/P/
+ta
+# Yes it was empty. First occurrence. Remove the line.
+g
+d
+bb
+:a
+# The hold space was nonempty. Following occurrences. Do nothing.
+x
+:b
+}
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb
index a46a40d492..f008a792d4 100644
--- a/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb
+++ b/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb
@@ -1,6 +1,7 @@
SRC_URI = "file://aclocal.tgz \
file://config.rpath \
file://Makefile.in.in \
+ file://remove-potcdate.sin \
file://COPYING"
INHIBIT_DEFAULT_DEPS = "1"
@@ -11,7 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0854da868a929923087141d9d7aba7d5"
inherit native
-PR = "r4"
+PR = "r5"
S = "${WORKDIR}"
@@ -21,4 +22,5 @@ do_install () {
install -d ${D}${datadir}/gettext/po/
cp ${WORKDIR}/config.rpath ${D}${datadir}/gettext/
cp ${WORKDIR}/Makefile.in.in ${D}${datadir}/gettext/po/
+ cp ${WORKDIR}/remove-potcdate.sin ${D}${datadir}/gettext/po/
}
diff --git a/meta/recipes-core/gettext/gettext_0.18.1.1.bb b/meta/recipes-core/gettext/gettext_0.18.1.1.bb
index c3265e1a22..4639481a54 100644
--- a/meta/recipes-core/gettext/gettext_0.18.1.1.bb
+++ b/meta/recipes-core/gettext/gettext_0.18.1.1.bb
@@ -5,7 +5,7 @@ SECTION = "libs"
LICENSE = "GPLv3+ & LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-PR = "r18"
+PR = "r19"
DEPENDS = "gettext-native virtual/libiconv ncurses expat"
DEPENDS_class-native = "gettext-minimal-native"
PROVIDES = "virtual/libintl virtual/gettext"
@@ -104,6 +104,7 @@ do_install_append_class-native () {
rm ${D}${datadir}/aclocal/*
rm ${D}${datadir}/gettext/config.rpath
rm ${D}${datadir}/gettext/po/Makefile.in.in
+ rm ${D}${datadir}/gettext/po/remove-potcdate.sin
}
BBCLASSEXTEND = "native nativesdk"