aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-core/gettext
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-contrib-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/gettext')
-rw-r--r--meta/recipes-core/gettext/gettext-0.17/autotools.patch62
-rw-r--r--meta/recipes-core/gettext/gettext-0.17/gettext-error_print_progname.patch13
-rw-r--r--meta/recipes-core/gettext/gettext-0.17/m4fix.patch50
-rw-r--r--meta/recipes-core/gettext/gettext-0.17/use_open_properly.patch15
-rw-r--r--meta/recipes-core/gettext/gettext-0.17/wchar-uclibc.patch96
-rw-r--r--meta/recipes-core/gettext/gettext_0.17.bb55
6 files changed, 291 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext-0.17/autotools.patch b/meta/recipes-core/gettext/gettext-0.17/autotools.patch
new file mode 100644
index 0000000000..9f16b1881f
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-0.17/autotools.patch
@@ -0,0 +1,62 @@
+Index: gettext-0.17/gettext-runtime/man/Makefile.am
+===================================================================
+--- gettext-0.17.orig/gettext-runtime/man/Makefile.am 2007-10-07 21:37:36.000000000 +0200
++++ gettext-0.17/gettext-runtime/man/Makefile.am 2008-05-09 22:46:37.000000000 +0200
+@@ -158,8 +158,7 @@
+ $(MAN2HTML) $(srcdir)/bind_textdomain_codeset.3.in | sed -e '/CreationDate:/d' > t-$@
+ mv t-$@ $@
+
+-install-html-local:
+- $(mkdir_p) $(DESTDIR)$(htmldir)
++install-html: installdirs-html
+ for file in $(man_HTML); do \
+ if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
+ $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
+Index: gettext-0.17/gettext-tools/man/Makefile.am
+===================================================================
+--- gettext-0.17.orig/gettext-tools/man/Makefile.am 2007-10-28 00:18:37.000000000 +0200
++++ gettext-0.17/gettext-tools/man/Makefile.am 2008-05-09 22:46:37.000000000 +0200
+@@ -186,8 +186,7 @@
+ $(MAN2HTML) `if test -f autopoint.1; then echo .; else echo $(srcdir); fi`/autopoint.1 | sed -e '/CreationDate:/d' > t-$@
+ mv t-$@ $@
+
+-install-html-local:
+- $(mkdir_p) $(DESTDIR)$(htmldir)
++install-html: installdirs-html
+ for file in $(man_HTML); do \
+ if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
+ $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
+Index: gettext-0.17/gettext-runtime/libasprintf/configure.ac
+===================================================================
+--- gettext-0.17.orig/gettext-runtime/libasprintf/configure.ac 2008-05-09 22:53:42.000000000 +0200
++++ gettext-0.17/gettext-runtime/libasprintf/configure.ac 2008-05-09 22:53:54.000000000 +0200
+@@ -1,5 +1,5 @@
+ dnl Configuration for the GNU libasprintf library
+-dnl Copyright (C) 2002-2006 Free Software Foundation, Inc.
++dnl Copyright (C) 2002-2007 Free Software Foundation, Inc.
+ dnl
+ dnl This program is free software: you can redistribute it and/or modify
+ dnl it under the terms of the GNU General Public License as published by
+@@ -54,8 +54,7 @@
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_INLINE
+ AC_TYPE_SIZE_T
+-gl_AC_TYPE_LONG_LONG
+-gt_TYPE_LONGDOUBLE
++AC_TYPE_LONG_LONG_INT
+ gt_TYPE_WCHAR_T
+ gt_TYPE_WINT_T
+ AC_CHECK_TYPE([ptrdiff_t], ,
+@@ -79,8 +78,11 @@
+ AC_SUBST([ALLOCA_H])
+
+ AC_CHECK_FUNCS([snprintf vasprintf wcslen])
+-AC_CHECK_DECLS([_snprintf])
++dnl Use the _snprintf function only if it is declared (because on NetBSD it
++dnl is defined as a weak alias of snprintf; we prefer to use the latter).
++AC_CHECK_DECLS([_snprintf], , , [#include <stdio.h>])
+ gt_PRINTF_POSIX
++gl_EOVERFLOW
+
+ dnl Check for tools needed for formatting the documentation.
+ ac_aux_dir_abs=`cd $ac_aux_dir && pwd`
diff --git a/meta/recipes-core/gettext/gettext-0.17/gettext-error_print_progname.patch b/meta/recipes-core/gettext/gettext-0.17/gettext-error_print_progname.patch
new file mode 100644
index 0000000000..0f67cd0b2e
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-0.17/gettext-error_print_progname.patch
@@ -0,0 +1,13 @@
+Index: gettext-0.17/gettext-tools/libgettextpo/error.h
+===================================================================
+--- gettext-0.17.orig/gettext-tools/libgettextpo/error.h 2008-07-27 21:16:25.561115527 +0200
++++ gettext-0.17/gettext-tools/libgettextpo/error.h 2008-07-27 21:16:52.454440505 +0200
+@@ -49,7 +49,7 @@
+ /* If NULL, error will flush stdout, then print on stderr the program
+ name, a colon and a space. Otherwise, error will call this
+ function without parameters instead. */
+-extern DLL_VARIABLE void (*error_print_progname) (void);
++void (*error_print_progname) (void);
+
+ /* This variable is incremented each time `error' is called. */
+ extern DLL_VARIABLE unsigned int error_message_count;
diff --git a/meta/recipes-core/gettext/gettext-0.17/m4fix.patch b/meta/recipes-core/gettext/gettext-0.17/m4fix.patch
new file mode 100644
index 0000000000..a02457fab8
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-0.17/m4fix.patch
@@ -0,0 +1,50 @@
+When I try to `./autogen.sh --quick' CVS gettext, using git Autoconf,
+things fall over like this (several instances):
+
+| gnulib-m4/openmp.m4:29: error: m4_copy: won't overwrite defined macro:
+_AC_LANG_OPENMP(C++)
+| gnulib-m4/openmp.m4:29: the top level
+| autom4te: /usr/bin/m4 failed with exit status: 1
+| aclocal: autom4te failed with exit status: 1
+
+I'm not quite sure whether an Autoconf bug/incompatibility is involved
+here (therefore the Cc: to bug-autoconf). m4_copy wasn't documented in
+earlier Autoconf releases, but there may still have been problematic
+semantic changes, I don't know.
+
+Anyway, the following patch seems to fix it. OK to apply?
+
+Cheers,
+Ralf
+
+2008-12-03 Ralf Wildenhues <[EMAIL PROTECTED]>
+
+ * m4/openmp.m4 (AC_OPENMP): Do not define with Autoconf 2.62 or
+ newer.
+
+Index: gettext-0.17/gettext-tools/gnulib-m4/openmp.m4
+===================================================================
+--- gettext-0.17.orig/gettext-tools/gnulib-m4/openmp.m4 2010-02-01 10:51:00.437788710 +0000
++++ gettext-0.17/gettext-tools/gnulib-m4/openmp.m4 2010-02-01 10:51:50.697789220 +0000
+@@ -1,11 +1,13 @@
+-# openmp.m4 serial 4
+-dnl Copyright (C) 2006-2007 Free Software Foundation, Inc.
++# openmp.m4 serial 5
++dnl Copyright (C) 2006-2008 Free Software Foundation, Inc.
+ dnl This file is free software; the Free Software Foundation
+ dnl gives unlimited permission to copy and/or distribute it,
+ dnl with or without modifications, as long as this notice is preserved.
+
+ dnl This file can be removed once we assume autoconf >= 2.62.
+
++m4_version_prereq([2.62],, [
++
+ # _AC_LANG_OPENMP
+ # ---------------
+ # Expands to some language dependent source code for testing the presence of
+@@ -90,3 +92,5 @@
+ fi
+ AC_SUBST([OPENMP_]_AC_LANG_PREFIX[FLAGS])
+ ])
++
++])
diff --git a/meta/recipes-core/gettext/gettext-0.17/use_open_properly.patch b/meta/recipes-core/gettext/gettext-0.17/use_open_properly.patch
new file mode 100644
index 0000000000..111714b543
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-0.17/use_open_properly.patch
@@ -0,0 +1,15 @@
+Index: gettext-0.17/gettext-tools/src/write-catalog.c
+===================================================================
+--- gettext-0.17.orig/gettext-tools/src/write-catalog.c 2008-10-16 15:18:16.000000000 +0200
++++ gettext-0.17/gettext-tools/src/write-catalog.c 2008-10-16 18:17:13.000000000 +0200
+@@ -220,7 +220,9 @@
+ /* Open the output file. */
+ if (!to_stdout)
+ {
+- fd = open (filename, O_WRONLY | O_CREAT);
++ fd = open (filename, O_WRONLY | O_CREAT,
++ /* 0666 in portable POSIX notation: */
++ S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH | S_IWOTH);
+ if (fd < 0)
+ {
+ const char *errno_description = strerror (errno);
diff --git a/meta/recipes-core/gettext/gettext-0.17/wchar-uclibc.patch b/meta/recipes-core/gettext/gettext-0.17/wchar-uclibc.patch
new file mode 100644
index 0000000000..7b3880bf77
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-0.17/wchar-uclibc.patch
@@ -0,0 +1,96 @@
+Index: gettext-0.17/gettext-runtime/gnulib-lib/wchar.in.h
+===================================================================
+--- gettext-0.17.orig/gettext-runtime/gnulib-lib/wchar.in.h 2008-07-29 14:51:52.336394636 +0200
++++ gettext-0.17/gettext-runtime/gnulib-lib/wchar.in.h 2008-07-29 14:52:25.546430195 +0200
+@@ -1,6 +1,6 @@
+ /* A substitute for ISO C99 <wchar.h>, for platforms that have issues.
+
+- Copyright (C) 2007 Free Software Foundation, Inc.
++ Copyright (C) 2007-2008 Free Software Foundation, Inc.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+@@ -26,6 +26,14 @@
+ * the declaration of wcwidth().
+ */
+
++#ifdef __need_mbstate_t
++/* Special invocation convention inside uClibc header files. */
++
++#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
++
++#else
++/* Normal invocation convention. */
++
+ #ifndef _GL_WCHAR_H
+
+ /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
+@@ -80,3 +88,4 @@
+
+ #endif /* _GL_WCHAR_H */
+ #endif /* _GL_WCHAR_H */
++#endif
+Index: gettext-0.17/gettext-tools/gnulib-lib/wchar.in.h
+===================================================================
+--- gettext-0.17.orig/gettext-tools/gnulib-lib/wchar.in.h 2008-07-29 14:52:03.886393956 +0200
++++ gettext-0.17/gettext-tools/gnulib-lib/wchar.in.h 2008-07-29 14:52:50.876388000 +0200
+@@ -1,6 +1,6 @@
+ /* A substitute for ISO C99 <wchar.h>, for platforms that have issues.
+
+- Copyright (C) 2007 Free Software Foundation, Inc.
++ Copyright (C) 2007-2008 Free Software Foundation, Inc.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+@@ -26,6 +26,14 @@
+ * the declaration of wcwidth().
+ */
+
++#ifdef __need_mbstate_t
++/* Special invocation convention inside uClibc header files. */
++
++#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
++
++#else
++/* Normal invocation convention. */
++
+ #ifndef _GL_WCHAR_H
+
+ /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
+@@ -80,3 +88,4 @@
+
+ #endif /* _GL_WCHAR_H */
+ #endif /* _GL_WCHAR_H */
++#endif
+Index: gettext-0.17/gettext-tools/libgettextpo/wchar.in.h
+===================================================================
+--- gettext-0.17.orig/gettext-tools/libgettextpo/wchar.in.h 2008-07-29 14:51:58.826395009 +0200
++++ gettext-0.17/gettext-tools/libgettextpo/wchar.in.h 2008-07-29 14:52:38.609723575 +0200
+@@ -1,6 +1,6 @@
+ /* A substitute for ISO C99 <wchar.h>, for platforms that have issues.
+
+- Copyright (C) 2007 Free Software Foundation, Inc.
++ Copyright (C) 2007-2008 Free Software Foundation, Inc.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+@@ -26,6 +26,14 @@
+ * the declaration of wcwidth().
+ */
+
++#ifdef __need_mbstate_t
++/* Special invocation convention inside uClibc header files. */
++
++#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
++
++#else
++/* Normal invocation convention. */
++
+ #ifndef _GL_WCHAR_H
+
+ /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
+@@ -80,3 +88,4 @@
+
+ #endif /* _GL_WCHAR_H */
+ #endif /* _GL_WCHAR_H */
++#endif
diff --git a/meta/recipes-core/gettext/gettext_0.17.bb b/meta/recipes-core/gettext/gettext_0.17.bb
new file mode 100644
index 0000000000..c945891e26
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.17.bb
@@ -0,0 +1,55 @@
+DESCRIPTION = "The GNU internationalization library."
+HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
+SECTION = "libs"
+LICENSE = "GPLv3"
+PR = "r5"
+DEPENDS = "gettext-native virtual/libiconv ncurses expat"
+DEPENDS_virtclass-native = ""
+PROVIDES = "virtual/libintl"
+PROVIDES_virtclass-native = ""
+
+SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
+ file://autotools.patch;patch=1 \
+ file://wchar-uclibc.patch;patch=1 \
+ file://use_open_properly.patch;patch=1 \
+ file://m4fix.patch;patch=1 \
+ "
+
+SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"
+SRC_URI_append_linux-uclibcgnueabi = " file://gettext-error_print_progname.patch;patch=1"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+EXTRA_OECONF += "--without-lispdir \
+ --disable-csharp \
+ --disable-libasprintf \
+ --disable-java \
+ --disable-native-java \
+ --disable-openmp \
+ --with-included-glib \
+ --with-libncurses-prefix=${STAGING_LIBDIR}/.. \
+ --without-emacs \
+ "
+
+acpaths = '-I ${S}/autoconf-lib-link/m4/ \
+ -I ${S}/gettext-runtime/m4 \
+ -I ${S}/gettext-tools/m4'
+
+
+# these lack the .x behind the .so, but shouldn't be in the -dev package
+# Otherwise you get the following results:
+# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
+# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
+# because gettext depends on gettext-dev, which pulls in more -dev packages:
+# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
+# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
+# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
+# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
+
+PACKAGES =+ "libgettextlib libgettextsrc"
+FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
+FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
+
+BBCLASSEXTEND = "native nativesdk"