aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.18.1.1.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-05-24 14:53:51 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-01 18:32:26 +0100
commit13fff2baf108e07eaf2d7e4c982bbdf9089c6bad (patch)
tree6f6391db5b97da5ab9d92bc2d89ff185b9eb696e /meta/recipes-core/gettext/gettext_0.18.1.1.bb
parent089a577bbe89be35ed5b6c147eed87440a9936da (diff)
downloadopenembedded-core-contrib-13fff2baf108e07eaf2d7e4c982bbdf9089c6bad.tar.gz
gettext: Update to 0.18.1.1
Add Upstream Status tags to patches Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.18.1.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.18.1.1.bb84
1 files changed, 84 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.18.1.1.bb b/meta/recipes-core/gettext/gettext_0.18.1.1.bb
new file mode 100644
index 0000000000..fe1b2662a0
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.18.1.1.bb
@@ -0,0 +1,84 @@
+SUMMARY = "Utilities and libraries for producing multi-lingual messages."
+DESCRIPTION = "Gettext offers to programmers, translators, and even users, a well integrated set of tools and documentation. Specifically, the GNU `gettext' utilities are a set of tools that provides a framework to help other GNU packages produce multi-lingual messages. These tools include a set of conventions about how programs should be written to support message catalogs, a directory and file naming organization for the message catalogs themselves, a runtime library supporting the retrieval of translated messages, and a few stand-alone programs to massage in various ways the sets of translatable strings, or already translated strings."
+HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
+SECTION = "libs"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+PR = "r0"
+DEPENDS = "gettext-native virtual/libiconv ncurses expat"
+DEPENDS_virtclass-native = ""
+PROVIDES = "virtual/libintl virtual/gettext"
+PROVIDES_virtclass-native = ""
+CONFLICTS_${PN} = "proxy-libintl"
+SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
+ file://wchar-uclibc.patch \
+ "
+
+SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"
+SRC_URI_append_linux-uclibceabi = " file://gettext-error_print_progname.patch;patch=1"
+
+SRC_URI[md5sum] = "3dd55b952826d2b32f51308f2f91aa89"
+SRC_URI[sha256sum] = "93ac71a7afa5b70c1b1032516663658c51e653087f42a3fc8044752c026443e9"
+
+#PARALLEL_MAKE = ""
+
+inherit autotools
+
+EXTRA_OECONF += "--without-lispdir \
+ --disable-csharp \
+ --disable-libasprintf \
+ --disable-java \
+ --disable-native-java \
+ --disable-openmp \
+ --with-included-glib \
+ --with-libncurses-prefix=${STAGING_LIBDIR}/.. \
+ --without-emacs \
+ "
+
+acpaths = '-I ${S}/gettext-runtime/m4 \
+ -I ${S}/gettext-tools/m4'
+
+
+# these lack the .x behind the .so, but shouldn't be in the -dev package
+# Otherwise you get the following results:
+# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
+# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
+# because gettext depends on gettext-dev, which pulls in more -dev packages:
+# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
+# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
+# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
+# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
+PACKAGES =+ "gettext-runtime gettext-runtime-dev gettext-runtime-doc"
+
+FILES_gettext-runtime = "${bindir}/gettext \
+ ${bindir}/ngettext \
+ ${bindir}/envsubst \
+ ${bindir}/gettext.sh \
+ ${libdir}/libasprintf.so* \
+ ${libdir}/GNU.Gettext.dll \
+ "
+FILES_gettext-runtime_append_libc-uclibc = " ${libdir}/libintl.so* \
+ ${libdir}/charset.alias \
+ "
+FILES_gettext-runtime-dev += "${libdir}/libasprintf.a \
+ ${includedir}/autosprintf.h \
+ "
+FILES_gettext-runtime-dev_append_libc-uclibc = " ${libdir}/libintl.a \
+ ${includedir}/libintl.h \
+ "
+FILES_gettext-runtime-doc = "${mandir}/man1/gettext.* \
+ ${mandir}/man1/ngettext.* \
+ ${mandir}/man1/envsubst.* \
+ ${mandir}/man1/.* \
+ ${mandir}/man3/* \
+ ${docdir}/gettext/gettext.* \
+ ${docdir}/gettext/ngettext.* \
+ ${docdir}/gettext/envsubst.* \
+ ${docdir}/gettext/*.3.html \
+ ${datadir}/gettext/ABOUT-NLS \
+ ${docdir}/gettext/csharpdoc/* \
+ ${docdir}/libasprintf/autosprintf.html \
+ ${infodir}/autosprintf.info \
+ "
+BBCLASSEXTEND = "native nativesdk"