summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ell/ell_0.51.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-06-21 22:16:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-22 22:40:25 +0100
commitbd63e0a8aaefe6f3ccb8239b51ae4637909f21b2 (patch)
treebd4865c389cedeef89644cd91770f5c1202234dd /meta/recipes-core/ell/ell_0.51.bb
parent667264b82156219f9ac50dbb013683ac4fbe0fad (diff)
downloadopenembedded-core-contrib-bd63e0a8aaefe6f3ccb8239b51ae4637909f21b2.tar.gz
ell: update 0.50 -> 0.51
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/ell/ell_0.51.bb')
-rw-r--r--meta/recipes-core/ell/ell_0.51.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-core/ell/ell_0.51.bb b/meta/recipes-core/ell/ell_0.51.bb
new file mode 100644
index 0000000000..806833bc7d
--- /dev/null
+++ b/meta/recipes-core/ell/ell_0.51.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Embedded Linux Library"
+HOMEPAGE = "https://01.org/ell"
+DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
+low-level functionality for system daemons. It typically has no \
+dependencies other than the Linux kernel, C standard library, and \
+libdl (for dynamic linking). While ELL is designed to be efficient \
+and compact enough for use on embedded Linux platforms, it is not \
+limited to resource-constrained systems."
+SECTION = "libs"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
+
+DEPENDS = "dbus"
+
+inherit autotools pkgconfig
+
+SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
+ file://0001-build-fix-time.h-related-breakage-on-musl.patch \
+ "
+SRC_URI[sha256sum] = "ba86cfa4aaf10151443edd63a7687914465d969f5dda00a2c1fcb11bd85e417f"
+
+do_configure:prepend () {
+ mkdir -p ${S}/build-aux
+}