summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ell/ell_0.44.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-09-22 21:13:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-11 18:41:02 +0100
commit1190b241d7b7ba815b34d63fabc0f5fc862d8837 (patch)
tree7043c51e8acaf242e1beb301296b969c07195277 /meta/recipes-core/ell/ell_0.44.bb
parent0bea76e84135cb5a0fb435f7115d1bcb47daefc0 (diff)
downloadopenembedded-core-contrib-1190b241d7b7ba815b34d63fabc0f5fc862d8837.tar.gz
ell: upgrade 0.43 -> 0.44
ver 0.44: Fix issue with allowing zero byte input for AEAD cipher. Fix issue with filling in DNS info in DHCP lease objects. Add support neighbor discovery utility helpers. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-core/ell/ell_0.44.bb')
-rw-r--r--meta/recipes-core/ell/ell_0.44.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-core/ell/ell_0.44.bb b/meta/recipes-core/ell/ell_0.44.bb
new file mode 100644
index 0000000000..d1f1691645
--- /dev/null
+++ b/meta/recipes-core/ell/ell_0.44.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Embedded Linux Library"
+HOMEPAGE = "https://01.org/ell"
+DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
+low-level functionality for system daemons. It typically has no \
+dependencies other than the Linux kernel, C standard library, and \
+libdl (for dynamic linking). While ELL is designed to be efficient \
+and compact enough for use on embedded Linux platforms, it is not \
+limited to resource-constrained systems."
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
+
+DEPENDS = "dbus"
+
+inherit autotools pkgconfig
+
+SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
+ file://0001-pem.c-do-not-use-rawmemchr.patch \
+ "
+SRC_URI[sha256sum] = "41a6f8fa4d285b52cb7a5a87bda3e7370ecaac02d94aaa7ec1a23f0480b8bc3f"
+
+do_configure:prepend () {
+ mkdir -p ${S}/build-aux
+}