summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ell/ell_0.35.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-26 10:27:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-31 11:56:38 +0000
commit69952f5bf247fc42103a249a48213017f50e319d (patch)
treed8d03dfd639208c2eba57db901065f7dfecefd91 /meta/recipes-core/ell/ell_0.35.bb
parentdf9535626c66e59c6769bd7cc285c6f26271c6aa (diff)
downloadopenembedded-core-contrib-69952f5bf247fc42103a249a48213017f50e319d.tar.gz
ell: upgrade 0.33 -> 0.35
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/ell/ell_0.35.bb')
-rw-r--r--meta/recipes-core/ell/ell_0.35.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-core/ell/ell_0.35.bb b/meta/recipes-core/ell/ell_0.35.bb
new file mode 100644
index 0000000000..ccc54b5ff7
--- /dev/null
+++ b/meta/recipes-core/ell/ell_0.35.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Embedded Linux Library"
+DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
+low-level functionality for system daemons. It typically has no \
+dependencies other than the Linux kernel, C standard library, and \
+libdl (for dynamic linking). While ELL is designed to be efficient \
+and compact enough for use on embedded Linux platforms, it is not \
+limited to resource-constrained systems."
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
+
+DEPENDS = "dbus"
+
+inherit autotools pkgconfig
+
+SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
+ file://0001-ell-add-missing-include-in-dhcp-server.patch \
+ file://0001-pem.c-do-not-use-rawmemchr.patch \
+ "
+SRC_URI[sha256sum] = "2bfe9da7781f65f1cb1595a5a068a3ae74d4b68b74f287c6f0c892cfe623913f"
+
+do_configure_prepend () {
+ mkdir -p ${S}/build-aux
+}