aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-07-17 23:39:40 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-18 14:28:44 +0100
commitae9748c614dc8e56cde3de2401c922607ed97620 (patch)
treea0010b925980317e8b13c44e7d51c7b02f000c90 /meta/recipes-core/eglibc
parent25745cf72056efc2250e8fdd99d6f30384472694 (diff)
downloadopenembedded-core-contrib-ae9748c614dc8e56cde3de2401c922607ed97620.tar.gz
eglibc: Fix build for e500 cores
e500 support needed to be updared to match eglibc 2.16 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/eglibc')
-rw-r--r--meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch31
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb3
2 files changed, 33 insertions, 1 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch b/meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch
new file mode 100644
index 0000000000..9dbb26e1e4
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch
@@ -0,0 +1,31 @@
+Match with the latest math_private restructuring in glibc
+
+as done here
+
+http://sourceware.org/ml/libc-alpha/2012-03/msg00302.html
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+Index: libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/math_private.h
+===================================================================
+--- libc.orig/ports/sysdeps/powerpc/powerpc32/e500/fpu/math_private.h 2012-07-17 22:58:20.340405923 -0700
++++ libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/math_private.h 2012-07-17 22:58:21.120405923 -0700
+@@ -1 +1 @@
+-#include <math/math_private.h>
++#include_next <sysdeps/generic/math_private.h>
+Index: libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/fraiseexcpt.c
+===================================================================
+--- libc.orig/ports/sysdeps/powerpc/powerpc32/e500/fpu/fraiseexcpt.c 2012-07-17 23:15:15.872405939 -0700
++++ libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/fraiseexcpt.c 2012-07-17 23:18:42.760405602 -0700
+@@ -23,7 +23,7 @@
+
+ #undef feraiseexcept
+
+-#define __FERAISEEXCEPT_INTERNAL feraiseexcept
++#define __FERAISEEXCEPT_INTERNAL __feraiseexcept
+ #include "../spe-raise.c"
+
+-libm_hidden_def (feraiseexcept)
++libm_hidden_ver (__feraiseexcept, feraiseexcept)
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index 09f5dbbe05..23a4130185 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "19383"
DEPENDS += "gperf-native"
-PR = "r0"
+PR = "r1"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_16"
@@ -22,6 +22,7 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=h
file://eglibc_fix_findidx_parameters.patch \
file://ppc_slow_ieee754_sqrt.patch \
file://rpc-bootstrap.patch \
+ file://e500-math_private.patch \
"
LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \