aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-07-23 22:36:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-26 14:39:49 +0100
commit3045ab9b3efc887700a922d06a6f5f4069a41356 (patch)
treebaf32e867bb1bd6cceff88b6ab4dcd72ce21e4c2 /meta/recipes-core/eglibc
parent3f4f6726646e18ae21919e2f361b669332796aef (diff)
downloadopenembedded-core-contrib-3045ab9b3efc887700a922d06a6f5f4069a41356.tar.gz
eglibc-initial: Fix build failure due to missing limits.h
We have had these things in place to overcome a limitation from our gcc-initial-cross not staging a self sufficient limits.h. Now thats fixed we do reset TOOLCHAIN_OPTIONS to point to sysroot where linux kernel headers are staged and not the bootstrap sysroot which will infact be popuated by eglibc-initial itself. Secondly we dont need to set CPPFLAGS specially as we are doing that in eglibc.inc so we override that Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/eglibc')
-rw-r--r--meta/recipes-core/eglibc/eglibc-initial.inc1
-rw-r--r--meta/recipes-core/eglibc/eglibc-initial_2.16.bb9
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb2
3 files changed, 8 insertions, 4 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-initial.inc b/meta/recipes-core/eglibc/eglibc-initial.inc
index 906251633b..1020e402d3 100644
--- a/meta/recipes-core/eglibc/eglibc-initial.inc
+++ b/meta/recipes-core/eglibc/eglibc-initial.inc
@@ -8,6 +8,7 @@ PACKAGES_DYNAMIC = ""
STAGINGCC = "gcc-cross-initial"
STAGINGCC_virtclass-nativesdk = "gcc-crosssdk-initial"
+TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
do_configure () {
sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
diff --git a/meta/recipes-core/eglibc/eglibc-initial_2.16.bb b/meta/recipes-core/eglibc/eglibc-initial_2.16.bb
index 787c762609..f6b09ac987 100644
--- a/meta/recipes-core/eglibc/eglibc-initial_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc-initial_2.16.bb
@@ -1,6 +1,9 @@
require eglibc_${PV}.bb
require eglibc-initial.inc
-do_configure_prepend () {
- unset CFLAGS
-}
+# main eglibc recipes muck with TARGET_CPPFLAGS to point into
+# final target sysroot but we
+# are not there when building eglibc-initial
+# so reset it here
+
+TARGET_CPPFLAGS = ""
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index b76d94320e..fc3d82bd8c 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "19383"
DEPENDS += "gperf-native"
-PR = "r1"
+PR = "r2"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_16"