aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.16.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-10-17 14:59:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-22 14:57:26 +0100
commit77ee4d7d88976c7bb2bb25b57e06b83edaacbd4c (patch)
tree61fab6cbcd7c80f2d6efc5322a898390503de640 /meta/recipes-core/eglibc/eglibc_2.16.bb
parent74b5f8943b2b29c7b3b62be7d81fb2b3a86b9584 (diff)
downloadopenembedded-core-contrib-77ee4d7d88976c7bb2bb25b57e06b83edaacbd4c.tar.gz
eglibc-2.16: Use tar ball instead of svn SRC_URI
Adapt the recipes to fetch a tarball. Tarball is generated from latest 2.16 branch which has e500-math_private.patch already applied hence we remove that patch. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.16.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb19
1 files changed, 9 insertions, 10 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index 2c1018f21c..56a0a38192 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -1,13 +1,9 @@
require eglibc.inc
-SRCREV = "20393"
-
DEPENDS += "gperf-native kconfig-frontends-native"
-PR = "r16"
-PR_append = "+svnr${SRCPV}"
+PR = "r17"
-EGLIBC_BRANCH="eglibc-2_16"
-SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=http \
+SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr21224.tar.bz2 \
file://eglibc-svn-arm-lowlevellock-include-tls.patch \
file://IO-acquire-lock-fix.patch \
file://mips-rld-map-check.patch \
@@ -21,7 +17,6 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=h
file://initgroups_keys.patch \
file://eglibc_fix_findidx_parameters.patch \
file://ppc_slow_ieee754_sqrt.patch \
- file://e500-math_private.patch \
file://fileops-without-wchar-io.patch \
file://add_resource_h_to_wait_h.patch \
file://0001-Avoid-use-of-libgcc_s-and-libgcc_eh-when-building-gl.patch \
@@ -33,6 +28,10 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=h
file://fsl-ppc-no-fsqrt.patch \
file://0001-R_ARM_TLS_DTPOFF32.patch \
"
+
+SRC_URI[md5sum] = "88894fa6e10e58e85fbd8134b8e486a8"
+SRC_URI[sha256sum] = "460a45f422da6eb1fd909baab6a64b5ae4c8ba18ea05a1491ed1024c8b98eeaa"
+
LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
@@ -41,7 +40,7 @@ LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch \
file://relocatable_sdk.patch \
"
-S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
+S = "${WORKDIR}/eglibc-${PV}/libc"
B = "${WORKDIR}/build-${TARGET_SYS}"
PACKAGES_DYNAMIC = ""
@@ -93,9 +92,9 @@ do_unpack_append() {
}
do_move_ports() {
- if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
+ if test -d ${WORKDIR}/eglibc-${PV}/ports ; then
rm -rf ${S}/ports
- mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
+ mv ${WORKDIR}/eglibc-${PV}/ports ${S}/
fi
}