aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc-package.inc
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-04-14 01:59:05 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-14 13:24:58 +0100
commit381bf0d364da5970682502f8f124264907587b87 (patch)
tree6476fc7bb619c723104198cd07246b9c8409f6ec /meta/recipes-core/eglibc/eglibc-package.inc
parentedbfba73e3cea86d08d67b8623ab385ded44ed55 (diff)
downloadopenembedded-core-contrib-381bf0d364da5970682502f8f124264907587b87.tar.gz
eglibc: fix builds on fedora 17 alpha
Generally distros keep perl at /sur/bin/perl Fedora 17 alpha also has /bin/perl this causes eglibc build on such distros to put perl interpreter path in the perl scripts as /bin/perl But we set perl location for target as /usr/bin/perl This mismatch of perl path causes failure of rootfs image creation like this: | error: Failed dependencies: | /bin/perl is needed by eglibc-utils-2.13-r23+svnr15508.i586 NOTE: package core-image-sato-1.0-r0: task do_rootfs: Failed ERROR: Task 8 (/home/nitin/prj/poky.git/meta/recipes-sato/images/core-image-sato.bb, do_rootfs) failed with exit code '1' This Fixes bug : [YOCTO #2286] RP: Updated to better account for -nativesdk Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc-package.inc')
-rw-r--r--meta/recipes-core/eglibc/eglibc-package.inc7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-package.inc b/meta/recipes-core/eglibc/eglibc-package.inc
index 9e45fc1fd5..0db221f128 100644
--- a/meta/recipes-core/eglibc/eglibc-package.inc
+++ b/meta/recipes-core/eglibc/eglibc-package.inc
@@ -72,10 +72,17 @@ DESCRIPTION_libsotruss = "Library to support sotruss which traces calls through
inherit libc-common multilib_header
+PERLPATH = "${bindir}/env perl"
+PERLPATH_virtclass-nativesdk = "/usr/bin/env perl"
+
do_install_append () {
rm -f ${D}${sysconfdir}/localtime
oe_multilib_header bits/syscall.h
+
+ if [ -f ${D}${bindir}/mtrace ]; then
+ sed -i -e '1s,#!.*perl,#! ${PERLPATH},' -e '2s,exec.*perl,exec ${PERLPATH},' ${D}${bindir}/mtrace
+ fi
}
do_install_locale () {