aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/cross-localedef-native_2.15.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-06 20:40:23 -0800
committerSaul Wold <sgw@linux.intel.com>2012-01-09 21:51:50 -0800
commit289d09176f8b6f66f6a7807b57f10e86939942f5 (patch)
treeadff6c96ab37208b1bc38ae3b28ac2ba40b0ef39 /meta/recipes-core/eglibc/cross-localedef-native_2.15.bb
parent553deffc8040afabd56b1c1d87a8a8d24bbae5d0 (diff)
downloadopenembedded-core-contrib-289d09176f8b6f66f6a7807b57f10e86939942f5.tar.gz
eglibc: Upgrade recipes 2.14 -> 2.15
Add patch to provide __finite_sqrt functions for ppc Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/eglibc/cross-localedef-native_2.15.bb')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.15.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.15.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.15.bb
new file mode 100644
index 0000000000..6f311fc33c
--- /dev/null
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.15.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Cross locale generation tool for eglibc"
+HOMEPAGE = "http://www.eglibc.org/home"
+SECTION = "libs"
+LICENSE = "LGPL"
+
+LIC_DIR = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
+LIC_FILES_CHKSUM = "file://${LIC_DIR}/LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9\
+ file://${LIC_DIR}/COPYING;md5=393a5ca445f6965873eca0259a17f833 \
+ file://${LIC_DIR}/posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
+ file://${LIC_DIR}/COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
+
+
+inherit native
+inherit autotools
+
+PR = "r0"
+SRCREV="15225"
+EGLIBC_BRANCH="eglibc-2_14"
+SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http "
+S = "${WORKDIR}/${EGLIBC_BRANCH}/localedef"
+
+do_unpack_append() {
+ bb.build.exec_func('do_move_ports', d)
+}
+
+do_move_ports() {
+ if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
+ rm -rf ${WORKDIR}/libc/ports
+ mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${WORKDIR}/libc/
+ fi
+}
+
+EXTRA_OECONF = "--with-glibc=${WORKDIR}/${EGLIBC_BRANCH}/libc"
+CFLAGS += "-DNOT_IN_libc=1"
+
+do_configure () {
+ ./configure ${EXTRA_OECONF}
+}
+
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/localedef ${D}${bindir}/cross-localedef
+}