aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2013-07-11 15:41:43 +0300
committerSaul Wold <sgw@linux.intel.com>2013-07-12 10:12:12 -0700
commite516f18d663447954082b5d2df6c1033cb9b4e65 (patch)
tree02b2d1418f223ef529b6ede3702106aa179b4c1a /meta/recipes-core/dbus/dbus-ptest_1.6.10.bb
parent6b70373923909a05bb4d99beb8105c732ee0b2de (diff)
downloadopenembedded-core-contrib-e516f18d663447954082b5d2df6c1033cb9b4e65.tar.gz
dbus: upgrade to 1.6.10
dbus-ptest also upgraded to 1.6.10 systemd-address.patch removed; included in upstream. Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/dbus/dbus-ptest_1.6.10.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-ptest_1.6.10.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb b/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb
new file mode 100644
index 0000000000..6c0f4040f8
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "D-Bus test package, only used for D-bus functionality test."
+HOMEPAGE = "http://dbus.freedesktop.org"
+SECTION = "base"
+LICENSE = "AFL-2 | GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
+ file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
+
+DEPENDS = "python-pygobject dbus dbus-glib"
+
+RDEPENDS_${PN} += "make"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://tmpdir.patch \
+ file://ptest.patch \
+ file://dbus-1.init \
+ file://run-ptest \
+ "
+
+SRC_URI[md5sum] = "de4970c20629aeb958a12132415b3630"
+SRC_URI[sha256sum] = "1f3d6f4a53a7121328f6cd685fc14440d72e6c0006ecb3312cc779c495915e86"
+
+S="${WORKDIR}/dbus-${PV}"
+FILESPATH = "${FILE_DIRNAME}/dbus-${PV}"
+
+inherit autotools pkgconfig gettext ptest
+
+EXTRA_OECONF_X = "${@base_contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
+EXTRA_OECONF_X_virtclass-native = "--without-x"
+
+EXTRA_OECONF = "--enable-tests \
+ --enable-modular-tests \
+ --enable-installed-tests \
+ --enable-checks \
+ --enable-asserts \
+ --enable-verbose-mode \
+ --disable-xml-docs \
+ --disable-doxygen-docs \
+ --disable-libaudit \
+ --with-xml=expat \
+ --with-systemdsystemunitdir=${systemd_unitdir}/system/ \
+ --with-dbus-test-dir=${PTEST_PATH} \
+ ${EXTRA_OECONF_X}"
+
+do_install() {
+}
+
+do_install_ptest() {
+ find ${D}${PTEST_PATH} -name Makefile | xargs sed -i 's/^Makefile:/_Makefile:/'
+}