aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-glib-0.98/test-install-makefile.patch
diff options
context:
space:
mode:
authorYao Zhao <yao.zhao@windriver.com>2012-07-17 16:46:30 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-19 17:13:39 +0100
commit9acc464905f8106c2828e1b7bb6ce9f9be810302 (patch)
tree630e59b348b486840e9f801af151189fcb467de9 /meta/recipes-core/dbus/dbus-glib-0.98/test-install-makefile.patch
parentaefa55f3553f00753d1eb95905086bc12bc5bfaa (diff)
downloadopenembedded-core-contrib-9acc464905f8106c2828e1b7bb6ce9f9be810302.tar.gz
dbus-glib: add support for install regression tests
dbus-glib.inc: default turn off unit test as libdbus-glib-1.so.2.2.2 will have unit test code if DBUS_BUILD_TESTS enabled. User can turn it on with PACKAGECONFIG_pn-dbus-glib = "tests" in local.conf or PACKAGECONFIG ??= "tests" in recipe itself. test-install-makefile.patch: install unit tests for test purpose Add tests and tests-dbg package. Signed-off-by: Yao Zhao <yao.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/dbus/dbus-glib-0.98/test-install-makefile.patch')
-rw-r--r--meta/recipes-core/dbus/dbus-glib-0.98/test-install-makefile.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-glib-0.98/test-install-makefile.patch b/meta/recipes-core/dbus/dbus-glib-0.98/test-install-makefile.patch
new file mode 100644
index 0000000000..2e8e178bb7
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-glib-0.98/test-install-makefile.patch
@@ -0,0 +1,48 @@
+Change Makefile.am to install regression tests for test package purpose.
+
+Upstream-Status: Inappropriate [test not install is for purpose from upstream]
+
+Signed-off-by: Yao Zhao <yao.zhao@windriver.com>
+
+diff --git a/test/Makefile.am b/test/Makefile.am
+index 7ba11a8..249f0e7 100644
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -13,7 +13,8 @@ else
+ TEST_BINARIES=
+ endif
+
+-noinst_PROGRAMS= $(TEST_BINARIES)
++testdir = $(datadir)/@PACKAGE@/tests
++test_PROGRAMS= $(TEST_BINARIES)
+
+ test_service_SOURCES= \
+ test-service.c
+diff --git a/test/interfaces/Makefile.am b/test/interfaces/Makefile.am
+index 3cb2c39..e6de67d 100644
+--- a/test/interfaces/Makefile.am
++++ b/test/interfaces/Makefile.am
+@@ -39,7 +39,8 @@ if DBUS_BUILD_TESTS
+
+ ## we use noinst_PROGRAMS not check_PROGRAMS for TESTS so that we
+ ## build even when not doing "make check"
+-noinst_PROGRAMS = test-service test-client
++testdir = $(datadir)/@PACKAGE@/tests/interfaces
++test_PROGRAMS = test-service test-client
+
+ test_service_SOURCES = \
+ test-interfaces.c \
+diff --git a/test/core/Makefile.am b/test/core/Makefile.am
+index ef6cb26..9786c3a 100644
+--- a/test/core/Makefile.am
++++ b/test/core/Makefile.am
+@@ -46,7 +46,8 @@ endif
+
+ ## we use noinst_PROGRAMS not check_PROGRAMS for TESTS so that we
+ ## build even when not doing "make check"
+-noinst_PROGRAMS = \
++testdir = $(datadir)/@PACKAGE@/tests/core
++test_PROGRAMS = \
+ test-dbus-glib \
+ test-service-glib \
+ $(THREAD_APPS) \