aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-08-03 14:12:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-05 17:12:59 +0100
commite9a49ebe3a1c83aa022eb07f3ca87b3d71c742f9 (patch)
tree2ab52bab24aec657f69a31d58fa7eb394e332727 /meta/recipes-core/coreutils
parentf235366c8a39679aa5beadf54a5e0ab7ece90d16 (diff)
downloadopenembedded-core-contrib-e9a49ebe3a1c83aa022eb07f3ca87b3d71c742f9.tar.gz
coreutils: Fix build on uclibc
coreutils has getloadavg.m4 of its own. So we need to make sure that we remove the portions which look into hardcoded /usr/local/lib paths. These tests are only for AIX so we dont lose much Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/coreutils')
-rw-r--r--meta/recipes-core/coreutils/coreutils-8.12/remove-usr-local-lib-from-m4.patch31
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.12.bb6
2 files changed, 35 insertions, 2 deletions
diff --git a/meta/recipes-core/coreutils/coreutils-8.12/remove-usr-local-lib-from-m4.patch b/meta/recipes-core/coreutils/coreutils-8.12/remove-usr-local-lib-from-m4.patch
new file mode 100644
index 0000000000..aac097a4ce
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils-8.12/remove-usr-local-lib-from-m4.patch
@@ -0,0 +1,31 @@
+We have problem using hardcoded directories like /usr/local here
+which will be checked for cross builds. This is a special case which
+is valid for AIX only. We do not have AIX as one of our supported
+build host or target. Therefore we get rid of the hardcoded paths
+and make life easier for cross compilation process.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [Upstream does care for AIX while we may not]
+
+Index: coreutils-8.12/m4/getloadavg.m4
+===================================================================
+--- coreutils-8.12.orig/m4/getloadavg.m4 2011-08-03 14:03:59.982197767 -0700
++++ coreutils-8.12/m4/getloadavg.m4 2011-08-03 14:04:20.402197763 -0700
+@@ -44,16 +44,6 @@ AC_CHECK_FUNC([getloadavg], [],
+ [LIBS="-lutil $LIBS" gl_have_func=yes])
+ fi
+
+- if test $gl_have_func = no; then
+- # There is a commonly available library for RS/6000 AIX.
+- # Since it is not a standard part of AIX, it might be installed locally.
+- gl_getloadavg_LIBS=$LIBS
+- LIBS="-L/usr/local/lib $LIBS"
+- AC_CHECK_LIB([getloadavg], [getloadavg],
+- [LIBS="-lgetloadavg $LIBS" gl_have_func=yes],
+- [LIBS=$gl_getloadavg_LIBS])
+- fi
+-
+ # Set up the replacement function if necessary.
+ if test $gl_have_func = no; then
+ AC_LIBOBJ([getloadavg])
diff --git a/meta/recipes-core/coreutils/coreutils_8.12.bb b/meta/recipes-core/coreutils/coreutils_8.12.bb
index 00746b908a..0004ce7fc8 100644
--- a/meta/recipes-core/coreutils/coreutils_8.12.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.12.bb
@@ -7,13 +7,15 @@ BUGTRACKER = "http://debbugs.gnu.org/coreutils"
LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
file://src/ls.c;startline=5;endline=16;md5=e1a509558876db58fb6667ba140137ad"
-PR = "r2"
+PR = "r3"
DEPENDS = "gmp"
DEPENDS_virtclass-native = ""
inherit autotools gettext
-SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.gz"
+SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.gz \
+ file://remove-usr-local-lib-from-m4.patch \
+ "
SRC_URI[md5sum] = "fce7999953a67243d00d75cc86dbcaa6"
SRC_URI[sha256sum] = "9e233a62c98a3378a7b0483d2ae3d662dbaf6cd3917d3830d3514665e12a85c8"